Continuous slow refresh makes acrobat plugin unusable in gtk2 embedding

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: mozillabugs.philipl, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When a pdf file is loaded by the acrobat plugin in gtk-embedded mozilla, whether
in galeon or TestGtkEmbed, the plugin refreshes continuously and very slowly,
taking 10 seconds or so do a full refresh and then starting again. This renders
the plugin unusable. In full mozilla-the-browser, this behaviour is not observed.

Steps to reproduce:

1) Have acrobat and plugin installed and verified to work in mozilla-the-browser
2) Browse to the given url with TestGtkEmbed
3) Watch bad things happen.
(Reporter)

Comment 1

16 years ago
Sorry, that's gtk2 embedding only. gtk1 embedding does not show this problem.
Summary: Continuous slow refresh makes acrobat plugin unusable in gtk embedding → Continuous slow refresh makes acrobat plugin unusable in gtk2 embedding
(Reporter)

Updated

16 years ago
Blocks: 98995
(Reporter)

Comment 2

16 years ago
Well, this bad behaviour is no longer reproduceable. As the bug was never
confirmed from within mozilla.org and no explicit fix was recorded, I'm closing
as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 3

16 years ago
I'm certainly seeing this behaviour with galeon 1.3.3.

Are you using newer (CVS) versions of either Mozilla or Galeon that makes this
problem go away?

Comment 4

16 years ago
This bug looks like it depends on #198954.  galeon-bin hogs all the CPU time
when viewing a .pdf file with the acrobat plulgin, just as mozilla does.  The
continuous redraw/refresh seems to be characteristic of gtk-embedded mozilla
only, however, as regular mozilla does not exhibit this behavior.
Depends on: 198954
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.