allow multiple independently scrollable views of bookmarks tree to allow editing large collections

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Daniel B., Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Bookmarks management should provide the ability to display different sections of
the bookmarks hierarchy at the same time.  Without this ability, it is very
hard (inconvenient and slow) to manage large collections of bookmarks.

For example, consider:
1. in one pane (or window), viewing a folder of bookmarks that need sorting 
   (e.g., the new bookmarks folder), 
2. picking one bookmark to file, 
3. scrolling around in a second pane to decide where the bookmark goes, 
4. dragging the bookmark to where it belongs (from the first pane to the 
   second),
5. returning to the first pane to pick another bookmark (especially a related
   one),
6. returning to the second pane to decided where the second bookmark goes 
   (especially when it's related and doesn't require any scrolling)
7. dragging the related bookmark to where it goes.

Without multiple, independent (but cross-draggable) views, note how the user 
can't quickly and easily:
a) return to the original location of the first bookmark to pick a second 
   bookmark to sort (step 5),
b) after picking a second bookmark, return to the new location of the first
   bookmark (step 6),
c) drag a bookmark from one location to a far-away location.

Note that ability to edit a document in multiple independently scrollable views
is a common feature of editors and word processors.  Notice how that lets you
work in (at least) two active areas of the document, say, an old section of text
that you are removing piece by piece as you write replacement text in a new 
section.

More importantly, recall how filesystems can be "edited" in multiple, 
independent views.  

(In MS Windows Explorer, you can open multiple windows.  In "Explore" mode, each
window shows an independently scrollable and collapsible/expandable view of the 
whole filesystem hierarchy.  In "Open" mode, each window has an independently 
configurable (e.g., large icons vs. details, etc.) view of part (one directory)
of the filesystem hierarchy.  

Please note that I'm not arguing that bookmark management should be as complex
as that, just showing that the principal or feature of having multiple views 
isn't just for word processing or other document editing.)

)


At a minimum, Mozilla should support showing two simultaneous views of the
bookmarks hierarchy.

Ideally, the use should not be limited to two views.  

I think that allowing multiple bookmarks windows (as opposed to supporting
splitting the window into two tree views) gives the user the most flexibility
in allocating horizontal and/or vertical screen space.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 23214 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Re-opened for re-consideration of "duplicate of 23214."

They are only duplicates at a high level (as requests to come up with a 
more-usable bookmarks-editing interface).

However, this report specifically requests "*multiple*, independent (but
cross-draggable) views."  

Report 23214 does not address having multiple views.

Although both reports mention Windows Explorer, report 23214 only addresses
the 2-pane "Explore" mode of Windows Explorer.  (The "Open" mode, when used 
with the "open in separate windows" option (as Macs at least used to work) is 
important too.)


If this report is set back to "RESOLVED DUPLICATE", then 23214 should have
an annotation that this report has specific additional information.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

15 years ago
QA Contact: kasumi → cpetersen0953

Comment 3

15 years ago
Enhancement
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

15 years ago
I think this bug report/enhancement request can be closed.

The combination of the "Open in new window" command in the context menu 
of bookmark folders in the Bookmarks window and the fact that the root
of the bookmarks hierarchy is now (1.5a) displayed provides the ability
requested by this report.

Comment 5

15 years ago
See also bug 225944, same bug for Firebird (has patch).
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: ben_seamonkey → p_ch
QA Contact: chrispetersen → bookmarks

Comment 7

13 years ago
*** Bug 301390 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
(In reply to comment #4)
> I think this bug report/enhancement request can be closed.
> 
> The combination of the "Open in new window" command in the context menu 
> of bookmark folders in the Bookmarks window and the fact that the root
> of the bookmarks hierarchy is now (1.5a) displayed provides the ability
> requested by this report.

agree. Marking WFM.

Status: NEW → RESOLVED
Last Resolved: 15 years ago13 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.