Image not automatically refreshing when changing combobox value with arrow keys

RESOLVED DUPLICATE of bug 126379

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 126379
15 years ago
14 years ago

People

(Reporter: Tim De Pauw, Assigned: saari (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030318
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030318

As you can see on the URL, I've got a SELECT and an IMG. When the SELECT
changes, a cookie is set and the IMG is updated. This event is caught using
SELECT's ONCHANGE property. When I use the mouse to select another option, the
image is repainted, but when I do so using the arrow keys, the cookie is set,
and the image source is updated but not repainted. When another window gains
focus and I go back to the page, the image is updated.

Reproducible: Always

Steps to Reproduce:
1. Surf to URL
2. Select another option in the combobox
3. Compare behavior of the thumbnail when using arrow keys or mouse to select option

Actual Results:  
Thumbnail is not updated when using arrow keys

Expected Results:  
Repaint the thumbnail in both cases

Comment 1

15 years ago
using the arrow keys to change the option does not fire onChange until the
<select> loses focus.  This is done because keyboard-only users typically do not
want onchange firing until they have actually made a selection.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Afaik that only applies when the combobox is expanded and not when it only
displays the selected option.
Sorry if I'm nagging, it just seems odd to me...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

14 years ago
Boris did explain it: the onchange isn't fired when changing the selection with
the keyboard until it loses focus. It doesn't matter if it is expanded or not.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

14 years ago
Thanks, I understand; I must've misinterpreted the dealie at the time.
You need to log in before you can comment on or make changes to this bug.