If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

importxml uses hardcoded default priority "P3"

RESOLVED FIXED in Bugzilla 2.22

Status

()

Bugzilla
Bug Import/Export & Moving
RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: servaas goossens, Assigned: Greg Hendricks)

Tracking

2.16.2
Bugzilla 2.22

Details

(Whiteboard: blocker will fix)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

When the list of priorities is modified in localconfig, and a bug is 
imported with an unsupported priority, then the priority 'P3' is assigned in
importxml.pl (line 419). This results in a bug with an invalid priority.

Reproducible: Always

Steps to Reproduce:
1. Install a fresh copy of bugzilla 
2. Modify the list of priorities in localconfig (and run checksetup)
3. import a bug with an invalid priority 

Actual Results:  
sanity check produces a red line like:
  Bug(s) found with invalid priority value


Expected Results:  
importxml should not insert a bug with invalid priority.
(Reporter)

Updated

15 years ago
Version: unspecified → 2.16.2
(Reporter)

Comment 1

15 years ago
*** Bug 198569 has been marked as a duplicate of this bug. ***
Probably what it needs to do is look up the default priority and use that instead.  
Assignee: myk → justdave
Status: UNCONFIRMED → NEW
Component: Creating/Changing Bugs → Bugzilla-General
Ever confirmed: true
Component: Bugzilla-General → Bug Import/Export & Moving
I cannot reproduce in 2.19.1.

I have just imported 300 bugs from an XML file I generated externally which had
a <priority> tag in the XML for each bug, and each was imported with its correct
priority.
(Assignee)

Updated

13 years ago
Depends on: 285614

Updated

13 years ago
Assignee: justdave → ghendricks
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Whiteboard: blocker will fix
(Assignee)

Comment 4

13 years ago
This is only the case if the priority that comes over from the move.pl is not in
the list of priorities for the importing installation.
I have changed it to use the defaultpriority parameter instead of the P3.

Comment 5

12 years ago
fixed by bug 285614
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.22
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.