If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No way to prevent default message format from being HTML

VERIFIED DUPLICATE of bug 47140

Status

MailNews Core
Composition
--
minor
VERIFIED DUPLICATE of bug 47140
15 years ago
9 years ago

People

(Reporter: Antonio M. D'souza, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

I don't think this happens in the Linux version but on Windows all my new
messages are set to be HTML format by default & I seem to have no way of
altering this. 
My preferences are set to convert everything to plaintext. 

Reproducible: Always

Steps to Reproduce:
1. Install Moz 1.3 on Windows
2. Set preferences to convert all outgoing messages to plain text. This may not
be necessary but I think it highlights the extent of the problem. 
3. Hit ctrl+M or the new message button in MailNews to open a new blank message
compostion window. 

Actual Results:  
There HTML formatting toolbar is visible. 

Expected Results:  
I would like it to assume all my outbound messages are plaintext by default. 

Replying to a message from my Inbox also sets HTML as the default format.
However, if I pick a card from my Addressbook that has the preferred message
format set to plaintext then the new composition window does not assume I want
an HTML format message.

Comment 1

15 years ago
Depending how one reads this bug it could be seen as a request for a
preference bug 115439. 

Otherwise this is bug 47140.

Reporter, please search bugzilla before filing a new bug [my search terms were
"default" and "HTML"]

*** This bug has been marked as a duplicate of 47140 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
Reporter: On the Mailnews menuline, click Edit->Mail and Newsgroups Accound
Settings. Uncheck "Compose messages in HTML format".
(Reporter)

Comment 3

15 years ago
Damn I missed that when I was searching in the Prefs for this option! I must
have unchecked it in my Linux profile...
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.