Non-portable multi-character literals in "nsExternalHelperAppService"

VERIFIED DUPLICATE of bug 120045

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 120045
16 years ago
16 years ago

People

(Reporter: Nils Hammar, Assigned: bz)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 Attempted build of 1.3 under HP-UX

The following warnings occurs while attempting a build under HP-UX 11.00/32.

Warning 728: "nsExternalHelperAppService.cpp", line 108 # Multicharacter charact
er literals are not portable.
      { TEXT_PLAIN, "txt,text", "Text File", 'TEXT', 'ttxt' },
                                             ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 108 # Multicharacter charact
er literals are not portable.
      { TEXT_PLAIN, "txt,text", "Text File", 'TEXT', 'ttxt' },
                                                     ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 109 # Multicharacter charact
er literals are not portable.
    TEXT_HTML, "html,htm,shtml,ehtml", "HyperText Markup Language", 'TEXT', 'MOS
S' },
                                                                    ^^^^^^

Warning 728: "nsExternalHelperAppService.cpp", line 109 # Multicharacter charact
er literals are not portable.
    L, "html,htm,shtml,ehtml", "HyperText Markup Language", 'TEXT', 'MOSS' },
                                                                    ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 110 # Multicharacter charact
er literals are not portable.
      { TEXT_RDF, "rdf", "Resource Description Framework", 'TEXT','ttxt' },
                                                           ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 110 # Multicharacter charact
er literals are not portable.
      { TEXT_RDF, "rdf", "Resource Description Framework", 'TEXT','ttxt' },
                                                                  ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 111 # Multicharacter charact
er literals are not portable.
      { TEXT_XUL, "xul", "XML-Based User Interface Language", 'TEXT', 'ttxt' },
                                                              ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 111 # Multicharacter charact
er literals are not portable.
    { TEXT_XUL, "xul", "XML-Based User Interface Language", 'TEXT', 'ttxt' },
                                                                    ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 112 # Multicharacter charact
er literals are not portable.
    TEXT_XML,          "xml,xsl,xbl", "Extensible Markup Language", 'TEXT', 'ttx
t' },
                                                                    ^^^^^^

Warning 728: "nsExternalHelperAppService.cpp", line 112 # Multicharacter charact
er literals are not portable.
    ,          "xml,xsl,xbl", "Extensible Markup Language", 'TEXT', 'ttxt' },
                                                                    ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 113 # Multicharacter charact
er literals are not portable.
    html+xml", "xhtml,xht", "Extensible HyperText Markup Language", 'TEXT', 'ttx
t' },
                                                                    ^^^^^^

Warning 728: "nsExternalHelperAppService.cpp", line 113 # Multicharacter charact
er literals are not portable.
    ", "xhtml,xht", "Extensible HyperText Markup Language", 'TEXT', 'ttxt' },
                                                                    ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 117 # Multicharacter charact
er literals are not portable.
      { TEXT_CSS, "css", "Style Sheet", 'TEXT', 'ttxt' },
                                        ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 117 # Multicharacter charact
er literals are not portable.
      { TEXT_CSS, "css", "Style Sheet", 'TEXT', 'ttxt' },
                                                ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 118 # Multicharacter charact
er literals are not portable.
      { APPLICATION_JAVASCRIPT, "js", "Javascript Source File", 'TEXT', 'ttxt' }
,
                                                                ^^^^^^

Warning 728: "nsExternalHelperAppService.cpp", line 118 # Multicharacter charact
er literals are not portable.
    APPLICATION_JAVASCRIPT, "js", "Javascript Source File", 'TEXT', 'ttxt' },
                                                                    ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 119 # Multicharacter charact
er literals are not portable.
      { MESSAGE_RFC822, "eml", "RFC-822 data", 'TEXT', 'MOSS' },
                                               ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 119 # Multicharacter charact
er literals are not portable.
      { MESSAGE_RFC822, "eml", "RFC-822 data", 'TEXT', 'MOSS' },
                                                       ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 128 # Multicharacter charact
er literals are not portable.
      { APPLICATION_XPINSTALL, "xpi", "XPInstall Install", 'xpi*','MOSS' },
                                                           ^^^^^^
Warning 728: "nsExternalHelperAppService.cpp", line 128 # Multicharacter charact
er literals are not portable.
      { APPLICATION_XPINSTALL, "xpi", "XPInstall Install", 'xpi*','MOSS' },
                                                                  ^^^^^^



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
-> uriloader
Assignee: seawood → dougt
Component: Build Config → Networking
QA Contact: granrose → benc
-> bz
Assignee: dougt → bzbarsky
They don't need to be portable -- they're only used in Mac code.  What _should_ 
happen is that we should not even build them on non-Mac platforms...

*** This bug has been marked as a duplicate of 120045 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
VERFIFIED/dupe.
Status: RESOLVED → VERIFIED
Summary: Non-portable multi-character literals. → Non-portable multi-character literals in "nsExternalHelperAppService"
You need to log in before you can comment on or make changes to this bug.