Including DOCTYPE line causes .css stylesheet file to be ignored

VERIFIED INVALID

Status

()

VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: robert.funnell, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.75 [en] (Win98; U)
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030322

When I have the complete DOCTYPE line in my HTML file (html_bug.html), Mozilla 
seems to ignore the linked stylesheet (bacon.css), although a style defined in 
the <head> is interpreted correctly. If I remove the 2nd half of the DOCTYPE 
line (as in html.html in the same directory) then the page is displayed 
correctly. Both Netscape 4.7 and IE 6 display the page correctly in both cases, 
with the bacon.css styles applied.

Reproducible: Always

Steps to Reproduce:
1. View http://audilab.bmed.mcgill.ca/~funnell/InforMed/Bacon/HTML/html_bug.html
2. View http://audilab.bmed.mcgill.ca/~funnell/InforMed/Bacon/HTML/html.html
3. Compare background colour and heading styles

Actual Results:  
Page html_bug.html is displayed incorrectly.

Expected Results:  
html_bug.html should look like html.html looks.

none.
Tools\Web Development\Javascript Console :
Error: The stylesheet
http://audilab.bmed.mcgill.ca/~funnell/InforMed/Bacon/bacon.css was not loaded
because its MIME type, "text/plain", is not "text/css".

Mozilla ignores the CSS in the standards mode if the server sends the wrong
mime-type. (in this case the broken server sends Text/plain instead of text/css )

Mozilla ignores the wrong mime-type in the quirks mode (you remove the doc-type)

-> invalid (broken sever)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
V.
Status: RESOLVED → VERIFIED

Comment 3

16 years ago
*** Bug 204789 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.