Doesn't receive data on port 21 when using ftp://

RESOLVED DUPLICATE of bug 465

Status

()

Core
Networking: FTP
RESOLVED DUPLICATE of bug 465
15 years ago
15 years ago

People

(Reporter: Ulli Conrad, Assigned: dougt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a; MultiZilla v1.4.0.2) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a; MultiZilla v1.4.0.2) Gecko/20030312

I figured out that Mozilla is trying to retrieve data on different ports when
using the file transfer protocol. The server I tried to access has a firewall,
letting port 21 requests passing by, but mozilla requests has been dropped
because it tried to get the data on ports like 17416. Even when I specified the
port in the URL bar like ftp://user:password@host:21

Reproducible: Always

Steps to Reproduce:
1. Accessing a file server with firewall, allowing port 21 requests
2. URL bar: ftp://user:password@host:21
3. Server shows dropped packets, Mozilla can't connect



Expected Results:  
Accessing the server on port 21

Comment 1

15 years ago
This sounds very strange. You are sure your own firewall doesn't block server
replies? Can you attach a sample of the ftp server-log?

Comment 2

15 years ago
btw.. mozilla should receive the data on any port. It is only the destination
port you adress with port 21 in the URL.

Comment 3

15 years ago
FTP always uses two connections, a control one and a data one. This makes the 
firewall rules more complicated than for HTTP.

Useful reference: http://slacksite.com/other/ftp.html

Mozilla only supports passive FTP currently; aside from that, I don't think 
there is a bug here. 

-> FTP
Assignee: law → dougt
Component: File Handling → Networking: FTP
QA Contact: petersen → benc
dupe of bug 465 (support active connections)

*** This bug has been marked as a duplicate of 465 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
Can you see if the server is accepting the PASV command?

telnet host ftp
USER anonymous
PASS mozilla@example.org
PASV
(what does it say for that command?)

We have separate bugs asking for error messages when a firewall breaks passive
transfer.
You need to log in before you can comment on or make changes to this bug.