[quirks]image with percentage height not displayed in paragraph in table

RESOLVED DUPLICATE of bug 88035

Status

()

RESOLVED DUPLICATE of bug 88035
16 years ago
15 years ago

People

(Reporter: axel.braun, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

In a table, there is a scaled image like
<P ALIGN=CENTER><IMG SRC="any_picture.jpg" NAME="Logo" ALIGN=CENTER WIDTH=81%
HEIGHT=60% BORDER=0></P>
The image is not displayed at all, only if the WIDTH an HEIGHT are reomved.
Konqueror is displaying correctly

Reproducible: Always

Steps to Reproduce:
1. go to page mentioned above - it is an example
2.
3.

Actual Results:  
Image not displayed

Expected Results:  
Display the image

Comment 1

16 years ago
This page is being rendered in Quirks mode.  When it is rendered in standards
mode it is rendered correctly.  I have narrowed it down to a table cell with a
<P>.  Inside the <P> is an image with the property height=% set. 

Suggest moving to layout.
-> layout
Assignee: asa → other
Component: Browser-General → Layout
QA Contact: asa → ian
I wasn't able to create a testcase based on the description in comment #2 that
would break in build 2003102804, Windows XP.
Summary: scaled images not displayed at all → [quirks]image with percentage height not displayed in paragraph in table
(Reporter)

Comment 4

15 years ago
OK, works on latest nightly build (2003111005, Linux)

Comment 5

15 years ago
I can't seem to recreate the testcase either.  I did find bug 166630 that seems
to be simular to this bug.
This got fixed in October, which is why testing in November builds didn't show
the problem...

*** This bug has been marked as a duplicate of 88035 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.