Extraneous characters "at" show up middle of left edge of browser screen.

RESOLVED INVALID

Status

()

Core
HTML: Parser
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: George Yundt, Assigned: harishd)

Tracking

({compat})

Trunk
x86
Windows 2000
compat
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.3) Gecko/20030312

The layout engine seems to add the two letter word "at" along the left edge in
the middle of a bunch of white space with no other characters.
Problem happens with Moz 1.3 in Win2K and WinME.
Mozilla 1.2.1 on Win 98, Netscape 4.7 on Win2K and IE on either OS do not have
the extraneous letters and work properly.

Reproducible: Always

Steps to Reproduce:
1.Go to www.mydanaher.com
2.
3.

Actual Results:  
Got the extraneous text "at" on left edge.

Expected Results:  
Should have had white space/no text on left edge.

Don't know if this helps but
Using classic theme
Have Calendar, Spelling, Diggler installed
Have min font preference set to 10
This is because there's content after </html>, including "<small>at</small>".
Harish, is it reasonable to drop anything after </html> or do we have quirks
that depend on that?
Assignee: other → harishd
Component: Layout → Parser
QA Contact: ian → dsirnapalli
(Assignee)

Comment 2

15 years ago
Chris: The parser does not regard </html> as end of document and I believe there
are tools that generate this kind of markup.
Yeah, I figured. :-( Reporter, do you have any contact with the developers of
the page?
(Reporter)

Comment 4

15 years ago
Reporter does work for the company that runs this web page
but, does not know the developers.  I could start digging to find a
contact if someone thought that would be helpful.

FWIW, the curious thing to me is that Mozilla 1.2.1 renders
this page fine and Mozilla 1.3 has the issue.
I'm not sure why IE doesn't render it; as harishd said, some (broken) pages
require rendering beyond </html> and this page definitely has a little wad of
content stuck just after that. The developers probably don't even know it's
there; it's more likely you can get them to clear it away than that we'll be
able to develop a workaround, I'm afraid.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: compat
Marking this INVALID since the page has been fixed and there's no testcase that
shows the bug.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.