The default bug view has changed. See this FAQ.

Status

()

Core
Networking: File
--
major
VERIFIED DUPLICATE of bug 84128
14 years ago
14 years ago

People

(Reporter: Steve Masticola, Assigned: dougt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

URLs of the form "file:"... don't do anything when you click on them. The
identical URL, pasted into the URL box at the top, works fine.

Reproducible: Always

Steps to Reproduce:
1.Create a web page with a link to a "file:..." type URL. HTML files duplicate
this bug fine.
2.Create the file under the URL.
3.Open the page and click the link.

Actual Results:  
Nothing happened.

Expected Results:  
Should have opened the file under the link.
Do you load the Html document with the file:// links with file://blah/foo.html
or from a webserver : http://blah/foo.html ?

If from a webserver : Why didn't you read the release notes before you filed
this bug ?
(Reporter)

Comment 2

14 years ago
As I stated, the URL specifies a resource identifier of "file."

A little civility would also be appreciated here...
I didn't saw you use 1.0. This means that there is no entry for this in the
release notes (but the 1.3 Release notes apply also in this point) but it also
means that your bug report is invalid because your build is older than 2 weeks.
We accept only bug reports from builds >2 weeks (or the latest Release=1.3)

Please do this :
a) type "javascript:" in your URL Bar and press Enter 
(should open the Javascript Console and of course without the "" )
b) click your link
c) Do you get an error like this :
Security Error: Content at http://bugzilla.mozilla.org/show_bug.cgi?id=199295
may not load or link to file:///H:/html/myhome.html

( I used the URl in the URL field of this bug and this is denied because the
link is called from a page loaded with http:// )
(Reporter)

Comment 4

14 years ago
Matti:

Thanks. That is indeed the culprit. I also downloaded Moz 1.3 and verified it there.

Is there a way I can override this, at least for specific URLs?  It causes an
interoperability problem for Swiki (at least for the way some of my colleagues
use it.)

Cheers,
- Steve.
yes, read the 1.3 Release notes (http://www.mozilla.org/releases/mozilla1.3/ )
under the security section (or search with "checkloaduri" )

-> invalid

We have a bug about a better error message (and not only in the Console) and
also about allowing file:// links.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID

Comment 6

14 years ago
everyone be nice, please.

If you did not see bug 122022 when searching, please let me know what you
searched for.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE

Comment 8

14 years ago
Yep.

pi
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.