store preferences in .properties instead of JS

RESOLVED DUPLICATE of bug 98533

Status

()

Core
Preferences: Backend
RESOLVED DUPLICATE of bug 98533
15 years ago
15 years ago

People

(Reporter: Cathleen, Assigned: Alec Flett)

Tracking

({memory-footprint})

Trunk
memory-footprint
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
 
(Assignee)

Comment 1

15 years ago
there's an existing bug on this somewhere, I'd LOVE if someone could find it.

The idea is that instead of storing stuff in all.js, we'd store it in
prefs.properties and then use XPCOM's nsPersistentProperties to read it, rather
than going through JS, which really has a large overhead.

And yeah yeah, I know there will be all sorts of pref migration issues, that
will all be covered here. Its possible that the inital version will just be #ifdefs
Status: NEW → ASSIGNED
(Assignee)

Updated

15 years ago
Keywords: footprint

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 98533 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.