Cookie fails to respond to request that should show a user is logged on to site.

RESOLVED DUPLICATE of bug 198870

Status

()

Core
Networking: Cookies
RESOLVED DUPLICATE of bug 198870
15 years ago
15 years ago

People

(Reporter: David Bate, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030325
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030325

After loggin on as a member to http://www.aus-city.com/cgi-bin/ultimatebb.cgi
the info from the cookie ubber2452020.2027 is not being read properly to show
that the user is logged on.  The site contines to show that the member is not
logged on.  Here is part of the code that reads the cookie:
var user_cookie = getCookie('ubber2452020.2027');

if(('' == user_cookie) || (null == user_cookie)) {
// User is not logged in
document.writeln('You are not logged in.' , ' <a
href="http://www.aus-city.com/cgi-bin/ultimatebb.cgi?ubb=login">Login</a> or <a
href="http://www.aus-city.com/cgi-bin/ultimatebb.cgi?ubb=agree">register</a>')
} else {
// User is logged in
var user_array=user_cookie.split("&");
user_array[2] = unescape(user_array[2]);
document.writeln('Hello, ', user_array[2]);
document.writeln('[ <a title="Click here to log out."
href="http://www.aus-city.com/cgi-bin/ultimatebb.cgi?ubb=logoff">log out</a> ]');

Even after logging in, it continues to show the user as not beening logged it. 
The 0319 version was the last nightly in which it has worked.  Most of not all
the UBB abd other bulletin style boards using the same code above, will fail to
register the user as logged on.  Problem started with the cookie and failed
logon with the Yahoo complaints..

Reproducible: Always

Steps to Reproduce:
1. Goto http://www.aus-city.com/cgi-bin/ultimatebb.cgi
2. Log on
3. System fails to show member as logged on.
4. Deleted cookies and tried again.
5. Same effect.

Actual Results:  
System should show "Hello, User Name" once user logs on, but instead shows "You
are not logged in."

Expected Results:  
See above..
(Reporter)

Comment 1

15 years ago
This problem also effects the users last message read pointers for each of the
forums ans it also fails to read the date info from the cookies..  The system
thinks that the user has never visited before and forces all of the messages as
not read.  This happens on all UBB and UBB type message forums, not just the one
site.  Usually with UBB forums, 5 cookies are created with user name and last
ddate visited info, and Mozilla does not read this info.  At first, it would not
allow you to logon, but when the Yahoo problem was soved this was the only thing
that remained.

Comment 2

15 years ago
David: this was a regression in recent trunk builds that was fixed yesterday.
Could you try downloading today's trunk (20030326xx) and testing?

I'll close this as duplicate for now, but if you still have problems with
cookies, feel free to post and I'll reopen.

*** This bug has been marked as a duplicate of 198870 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

15 years ago
Yes, it is now working with the 2003032611 version.  The version before that
2003032608 I think was, it was not working..  Thanks...
You need to log in before you can comment on or make changes to this bug.