Table not centered in other table

VERIFIED DUPLICATE of bug 1044

Status

()

P3
normal
VERIFIED DUPLICATE of bug 1044
19 years ago
19 years ago

People

(Reporter: richard, Assigned: pierre)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
On this login page to our company intranet, the cell of the outer table
specifies align="center", but the inner table does not appear in the center of
the cell, but on the left.

Comment 1

19 years ago
Created attachment 3036 [details]
XHTML testcase

Comment 2

19 years ago
Created attachment 3037 [details]
HTML testcase

Updated

19 years ago
Whiteboard: [TESTCASE]

Comment 3

19 years ago
The XHTML testcase shows the bug; after removing the DOCTYPE it works fine, see
HTML testcase. (Using build 2000022916 on NT4.0 sp5)

Comment 4

19 years ago
Created attachment 3348 [details]
Another XHTML testcase - with non-table contents of table

Comment 5

19 years ago
This bug may be related to bug 1802: "[4.xP]<tr align=left/right/center> not
working", ASSIGNED. In that bug report <td> cells are not inheriting alignment
from parent <tr> elements; in this case it is an inner table that is not
inheriting alignment from a parent <td> cell. Of course this could be just
a red herring.

Added another xhtml testcase, with a paragraph added inside the outer table.
The paragraph is centered properly, but the inner table isn't.

Tested with: 1999-12-08-08-M12 nightly binary on Windows NT 4.0sp3

Updated

19 years ago
Assignee: karnaze → pierre

Comment 6

19 years ago
Reassigning to Pierre.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

19 years ago
It's a dup of bug 1044, not bug 1802. The inner table doesn't inherit the style
from it's surrounding element which happens to be a cell of the outer table. The
problem would have been the same if the outer element had been something else, A
DIV for instance as described in bug 1044.


*** This bug has been marked as a duplicate of 1044 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Verified dup of #1044
You need to log in before you can comment on or make changes to this bug.