If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The image cannot be displayed, because it contains errors." message , while loading an Automatic Resized Image

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Hermann Schwab, Assigned: Jim Dunn)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030326
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030326

URL from bug 199420, if you get a crash, look there ;-)

If Preferences/Appearence/Enable automatic image resizing is enabled,
and I load an image which is big enough to be resized, I get this warning.
Started some days ago. My screensize is 800x600.

other URLs:
http://www.amdzone.com/articleimages/cpu/hammer/newisys/console.jpg  935x674 px
http://drevil.warpcore.org/ags/kq2vga-1.png   640x426 px

Reproducible: Always

Steps to Reproduce:
1.Make sure automatic resizing is enabled
2.load an image, which is resized
3.shift-reload to get the warning again

Actual Results:  
I get the warning, before the image starts loading resized,
but image is displayed correctly after loading.
Didn´t try it locally.


Expected Results:  
loaded without warning

is this bug related to Bugzilla Bug 121084 cache: Images requested twice -> "The
image cannot be displayed, because it contains errors." message ?

Setting component Layout  because that Bug was set to Layout.
(Reporter)

Comment 1

15 years ago
edited URL (http://http://drevil.warpcore.org/ags/kq2vga-1.png led to a
non-workplace-safe website ;-) 

bug still visible with Build ID 2003032704

Comment 2

15 years ago
bug 197646? [Which was duped to bug 113406]
(Reporter)

Comment 3

15 years ago
Thanks!
Bug 113406 is a bug for MacOSX: Mac can't handle images >4095 pixels
Bug 197646#c1 also for MacOSX, with a file of 850kb which can´t be handled by
MacOSX-Gecko, but other Gecko-Browsers.

In these bugs: The warning is displayed, no image loaded (on Mac)

In this bug: The warning is displayed while loading the image, then the image is
displayed.

If it is the same bug, then you got two bugs on Mac: this one, and the
not-loading of the image.

I thought it may be related to bug 121084, but Darin Fisher checked something in
two days ago, and I still see this bug with Build ID 2003032708 
http://bugzilla.mozilla.org/show_bug.cgi?id=121084#c217

Comment 4

15 years ago
Yeah it crashes me too using the 26th's build this might be related to
http://bugzilla.mozilla.org/show_bug.cgi?id=199492
(Reporter)

Comment 5

15 years ago
John, I don´t get a crash.
It is only a cosmetical error, displaying the errormessage that the image can´t
be displayed because of errors. 
If you are not believing this message and waiting till it has loaded, 
you get your image displayed.
But if you believe this error message, you´ve got no reason to stay longer on
this page.
So this should be fixed.
(Reporter)

Comment 6

15 years ago
REGRESSION
This bug is visible with current nightlies, but not with 1.3
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
(Reporter)

Comment 7

15 years ago
Regression between BuildID 2003031708 not showing and 2003032004 showing this bug.
TestURL crashed with BuildID 2003031908 in Module COOKIE.DLL
it's not ARI(Automatic Resized Image) problem.
since i've turned off, but there's still errors.
> The image “someimage” cannot be displayed, because it contains errors.
and soon crash for GPF in kernel32.dll

i'm use Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030327 Phoenix/0.5

PS: it's not tested on my win.net svr RC2
(Assignee)

Comment 9

15 years ago
On win2k I see the following:
-3/27/03 build, the error message and a crash
-1.4a release build, the error message, the image, i click reload, see
 error message, the image
-4/3/03 build, I don't see the error message.

I know that on 3/25 some code got checked in which sort of 
hurt images that got loaded as documents.  That has been fixed
post 1.4a but Boris's fix to bug 121084.

Any chance I can talk you into downloading today's (or newer) build
and trying it?
Assignee: other → jdunn
(Reporter)

Comment 10

15 years ago
Thanks, WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030403
wfm after reporters comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.