[mailviews] Custom view status type is incorrect on restart

VERIFIED DUPLICATE of bug 183158

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 183158
15 years ago
14 years ago

People

(Reporter: Jeremy Jones, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Custom Message Views with a "Status" filter have a different, incorrect status
type selected upon restart of the application. The status type that was selected
initially is replaced with a different type, which is reflected in the filtered
messages as well.

The mapping seems to be:
1. Forwarded becomes Read
2. Read becomes Replied
3. New becomes Read
4. Replied becomes Read


Reproducible: Always

Steps to Reproduce:
1. Create a new custom Message View where "Status" "is" then select any of the
available items.
2. Press OK, it works fine, then exit Mail.
3. Restart Mail.
4. Check the view again, and you'll see that the status type is not what you
selected.

Actual Results:  
The status type selection on the View setup GUI is incorrect, and the set of
filtered messages (if the custom view is selected) are also incorrect.

Expected Results:  
The status type selection should be correctly preserved after a restart of the
application.

Updated

15 years ago
Blocks: 201500

Comment 1

15 years ago
May be related to Bug 196787.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
dup of bug 183158

*** This bug has been marked as a duplicate of 183158 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
No longer blocks: 201500

Comment 3

15 years ago
verifying dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.