Mozilla crashes randomly without any visible rule. - Trunk [@ nsHttpConnection::Release]

RESOLVED DUPLICATE of bug 199492

Status

()

Core
Networking
--
critical
RESOLVED DUPLICATE of bug 199492
15 years ago
15 years ago

People

(Reporter: gandalf, Assigned: asa)

Tracking

({crash, qawanted, topcrash})

Trunk
x86
Windows XP
crash, qawanted, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
After using Mozilla 1.3 final for more than week, i installed over it trunk
20030326. Then i started reciving many crashes, so i decided to remove mozilla's
directory and install this trunk once more. I still see those bug, but i see one
more.

Mozilla crashes not after any action from me, usually when it's minimized or in
background, but sometimes during typeing into textarea, ot closing tab. I think
that it has to be a dupe, but it's very hard to find original bug, not knowing
what happens...

Here me TB: TB18520747Z and TB18520071M

If anyone could check them and say what's wrong, i'd try to find original one.
(Reporter)

Updated

15 years ago
Severity: normal → critical
Whiteboard: TB18520747Z, TB18520071M

Updated

15 years ago
Keywords: crash, stackwanted
(Reporter)

Comment 1

15 years ago
Next TB to collection: TB18522179K

Comment 2

15 years ago
could be bug 199492, 20030327 should be fixed.

Comment 3

15 years ago
Incident ID 18522179
Stack Signature 	0x3d888889 94aba315
Email Address 	gandalf@alladyn.art.pl
Product ID 	MozillaTrunk
Build ID 	2003032604
Trigger Time 	2003-03-27 07:53:35
Platform 	Win32
Operating System 	Windows NT 5.1 build 2600
Module 	
URL visited 	
User Comments 	
Trigger Reason 	Access violation
Source File Name 	
Trigger Line No. 	
Stack Trace 	
0x3d888889
nsHttpConnection::Release
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpConnection.cpp,
line 693]
nsHttpConnectionMgr::OnSocketEvent
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpConnectionMgr.cpp,
line 844] 

Incident ID 18520747
Stack Signature 	0x3d888889 a6f57a1c
Email Address 	
Product ID 	MozillaTrunk
Build ID 	2003032604
Trigger Time 	2003-03-27 07:16:22
Platform 	Win32
Operating System 	Windows NT 5.1 build 2600
Module 	
URL visited 	
User Comments 	
Trigger Reason 	Access violation
Source File Name 	
Trigger Line No. 	
Stack Trace 	
0x3d888889
nsHttpConnection::Release
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpConnection.cpp,
line 693]
nsHttpConnectionMgr::PruneDeadConnectionsCB
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpConnectionMgr.cpp,
line 296] 

This looks like a regression that started with 3/25 builds.  There aren't too
many crashes yet...but it is in the top 50 on the Trunk.
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking
Ever confirmed: true
Keywords: stackwanted → topcrash
Summary: Mozilla crashes randomly without any visible rule. → Mozilla crashes randomly without any visible rule. - Trunk [@ nsHttpConnection::Release]
(Reporter)

Comment 4

15 years ago
I can send next TB from next builds of Mozilla, will it help?

Comment 5

15 years ago
reporter: i doubt you can reproduce using a current build. if you can, then
please reopen and report new talkback ids

*** This bug has been marked as a duplicate of 199492 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: TB18520747Z, TB18520071M
Crash Signature: [@ nsHttpConnection::Release]
You need to log in before you can comment on or make changes to this bug.