During shutdown under "insufficient quota" conditions, ALL profile data, bookmarks, passwords, etc. are lost

VERIFIED DUPLICATE of bug 86501

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 86501
15 years ago
13 years ago

People

(Reporter: Matt G., Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When a process running on my machine goes awry, I start to get error messages
like "Insufficient quota: can't complete operation" when I start programs, etc.
 During this time, if I shut down Mozilla, ALL of my bookmarks, saved passwords,
preferences, and other settings are LOST!

I don't feel the precise circumstances relating to the data loss are the real
issue, since there are undoubtedly many factors that could prevent the update of
this information from successfully completing.  There's basically no excuse for
loss of settings from previous browser sessions - it should never happen.

Many strategies could be employed to avoid this problem.  For example, a flag
could be written to a file, indicating that a new copy of the data to be
modified is going to be written.  Once this flag has been written (and read
back), then the new copy is created.  The flag is updated to point to this new
copy, and then the names of the old and new settings are changed, before
completely removing the old settings.


Thanks for considering this issue.


Reproducible: Always

Steps to Reproduce:
I don't know exactly what happens to my machine that causes this.  However,
there are all sorts of resources that could be unavailable during shutdown or
other cases in which profile data is updated.  These include: file descriptors,
heap memory, disk space, etc.  Other factors could prevent clean modifications
to profile data, including network problems (if the profile data is stored on a
network-mounted volume).

Actual Results:  
All profile data was lost.  This includes bookmarks, saved passwords,
preferences, etc.

Expected Results:  
At minimum, previous profile data should have been kept, even if changes and
additions from this session were lost.

Comment 1

15 years ago
This has been fixed in recent builds.

Please use the latest Mozilla release when logging bugs

*** This bug has been marked as a duplicate of 86501 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.