Error in converting float value from SOAP response into JS value

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
16 years ago
a year ago

People

(Reporter: nisheeth_mozilla, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This bug will be exposed once bug 199555 is fixed.

How to reproduce:

1) Go to above URL.
2) Type a ticker symbol.  Hit "Get Stock Quote".
3) You will see "50.54999923706055" replace the ticker symbol you just typed in
the text box.

Expected behavior:

You should see "50.55" in the text box because that is the float value returned
in the SOAP response.

CCing dbradley because this is probably an error in XPC somewhere.

Comment 1

16 years ago
It's probably an issue in XPCConvert or nsIVariant. I don't know the SOAP code
well enough to know off the top of my head. Harish, feel free to assign this to
me and I'll take a look.
Component: XML → Web Services
taking SOAP bugs
Assignee: harishd → jgaunt

Updated

11 years ago
Assignee: mozilla → nobody
QA Contact: ashshbhatt → web-services
We dropped SOAP.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Updated

a year ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.