Short Summary in show_bug.cgi does not parse out HTML tags

RESOLVED DUPLICATE of bug 22041

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED DUPLICATE of bug 22041
15 years ago
5 years ago

People

(Reporter: Joseph Monti, Assigned: myk)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030318
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030318

When a summary contains an HTML tag (or any markup tag), the Short Summary field
at the top of show_bug.cgi does not parse the < and > characters to &lt; and
&gt; respectively. So tags are rendered as HTML instead of showing it as text in
the browser.

I could not find this bug in any other places where the summary is displayed.
(ex. it is displayed as expected in buglist.cgi)

Reproducible: Always

Steps to Reproduce:
1. Create new bug
2. Enter something like "this is a <ulink> tag" in summary
3. Procede to show_showbug.cgi

Actual Results:  
those steps would show "this is a tag" in Short Summary

Expected Results:  
"this is a <ulink> tag"

This was found at http://bugzilla.gnome.org/. I wish I could test this more, but
I dont have access to a testing bugzilla. I am also unable to see if the bug
still exists in versions more recent than Bugzilla version 2.10
This was fixed in version 2.12

*** This bug has been marked as a duplicate of 22041 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.