If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Lost a bunch of font choices after upgrade to latest RPM's in Redhat 8.0

RESOLVED WONTFIX

Status

Core Graveyard
GFX: Gtk
RESOLVED WONTFIX
15 years ago
9 years ago

People

(Reporter: Herb Rubin, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

In the font selection of Preferences, I cannot see any of my Adobe fonts to
select them. I lost the use of half my fonts!

It used to give me a choice for adobe-helvetica-iso8859-1 or adobe-times-iso8859-1
but not anymore.

Reproducible: Always

Steps to Reproduce:
1. Install Mozilla 1.0.1 on Redhat 8 and view available fonts. See adobe choices.
2. Upgrade to 1.3
3. Look at available fonts in the Preferences. See missing adobe fonts.

Actual Results:  
I notices many fonts missing from the Preferences list.

Expected Results:  
Displayed all fonts found in /usr/share/texmf/fonts directories (I think).

Comment 1

15 years ago
> fonts found in /usr/share/texmf/fonts

usually not.  look at the font path in /etc/X11/fs/config or /etc/X11/XF86Config-4

anyway, did you ugprade to the XFT RPM or the RH7 RPM?

you mentioned that adobe fonts disappeared.  what fonts remain?
(Reporter)

Comment 2

15 years ago
I upgraded to Gtk version of mozilla. Here's my config file font list...

catalogue = /usr/X11R6/lib/X11/fonts/korean,
        /usr/X11R6/lib/X11/fonts/misc:unscaled,
        /usr/X11R6/lib/X11/fonts/75dpi:unscaled,
        /usr/X11R6/lib/X11/fonts/100dpi:unscaled,
        /usr/X11R6/lib/X11/fonts/misc,
        /usr/X11R6/lib/X11/fonts/Type1,
        /usr/X11R6/lib/X11/fonts/Speedo,
        /usr/X11R6/lib/X11/fonts/cyrillic,
        /usr/X11R6/lib/X11/fonts/TTF,
        /usr/share/fonts/default/Type1,
        ,
        /usr/share/fonts/zh_CN/TrueType,
        /usr/share/fonts/zh_TW/TrueType,
        /usr/share/fonts/KOI8-R/misc:unscaled,
        /usr/share/fonts/KOI8-R/75dpi:unscaled,
        /usr/share/fonts/KOI8-R/100dpi:unscaled,
        /usr/share/fonts/KOI8-R/misc,
        /usr/share/fonts/KOI8-R/75dpi,
        /usr/share/fonts/KOI8-R/100dpi,
        /usr/share/fonts/ISO8859-2/misc:unscaled,
        /usr/share/fonts/ISO8859-2/75dpi:unscaled,
        /usr/share/fonts/ISO8859-2/100dpi:unscaled,
        /usr/share/fonts/ISO8859-2/misc,
        /usr/share/fonts/ISO8859-2/75dpi,
        /usr/share/fonts/ISO8859-2/100dpi,
        /usr/share/fonts/ja/misc:unscaled,
        /usr/share/fonts/ja/misc,
        /usr/share/fonts/ja/TrueType,
        /usr/share/fonts/ko/TrueType,
        /usr/lib/openoffice/share/fonts/truetype,
        /usr/share/AbiSuite/fonts

The fonts that appear in my drop down boxes are:

serif
Bitstream Charter
Century Schoolbook L
Courier
Courier 10 pitch
Fangsong ti
Lucinda Typewriter
Luxi Mono
Luxi Sans
Luxi Serif
Nimbus Mono L
Nimbus Roman No9 L
Nimbus Sans L
URW Bookman L
URW Chancery L
URW Gothic L
URW Palladio L
Utopia
ZYSong18030
Which exact RPM did you use?
This is in the wrong component -- please see the component descriptions.
Assignee: ben → blizzard
Component: Preferences → GFX: Gtk
QA Contact: sairuh → ian
(Reporter)

Comment 5

15 years ago
These are the RPM's that I installed from using "rpm -Uvh moz*.rpm"

mozilla-1.3-0_rh8_gtk2.i386.rpm
mozilla-chat-1.3-0_rh8_gtk2.i386.rpm
mozilla-devel-1.3-0_rh8_gtk2.i386.rpm
mozilla-dom-inspector-1.3-0_rh8_gtk2.i386.rpm
mozilla-js-debugger-1.3-0_rh8_gtk2.i386.rpm
mozilla-mail-1.3-0_rh8_gtk2.i386.rpm
mozilla-nspr-1.3-0_rh8_gtk2.i386.rpm
mozilla-nspr-devel-1.3-0_rh8_gtk2.i386.rpm
mozilla-nss-1.3-0_rh8_gtk2.i386.rpm
mozilla-nss-devel-1.3-0_rh8_gtk2.i386.rpm
mozilla-psm-1.3-0_rh8_gtk2.i386.rpm
Those RPMs use Fontconfig to get a list of fonts, check your fontconfig
configuration (/etc/fonts/fonts.conf)
(Assignee)

Comment 7

15 years ago
Yep.  Not a bug.  Mozilla w/ gtk2 uses the true type fonts on the system, not
the old X fonts.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

15 years ago
Is this to imply I should not have downloaded the Gtk2 version of Mozilla?

I still need an answer here?
(Assignee)

Comment 9

15 years ago
The gtk2 version, like gtk2 itself, uses the xft code by default.  Unless the
.pcf fonts are in the path for fontconfig they aren't going to be picked up. 
Normally they aren't, though, since they tend to have non-iso10646 encodings and
look pretty crappy. :P
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.