Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Javascript onChange event doesn't fire for the Select form control when changed using the keyboard

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Keyboard: Navigation
--
minor
RESOLVED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: Mark Thorne, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

I'm actually not sure if this was a design decision or what, but if you notice
with the test case when you navigate through the items using the keyboard the
onChange even doesn't fire (which should change the text below the select) until
you hit enter on the keyboard. It's certainly nothing serious, just something I
noticed which doesn't seem right.

Reproducible: Always

Steps to Reproduce:
n/a - see the testcase
Actual Results:  
n/a

Expected Results:  
In my opinion the onChange even should fire when the select form is changed when
using the keyboard witout having to hit enter.
(Reporter)

Comment 1

15 years ago
test it here -> http://www.ratchetsgame.com/kbonchange.htm

Comment 2

15 years ago
Yes, this is by design

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: JavaScript Engine → Keyboard: Navigation
QA Contact: pschwartau → sairuh
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.