pseudo-elements allowed at places other than the end of a selector

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
P2
normal
VERIFIED FIXED
20 years ago
5 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Peter Linss)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
See test #3 of the uri quoted.

This is an error-handling bug.


Note, BTW, that supporting
  P:first-line.three
as is being 'supported' in that test is not only a violation of CSS1, it
is also nonsensical. After all, how can a pseudo-class have a class? The
markup cannot access it to *give* it a class!!!

The correct CSS would be:
  P.three:first-line
which is perfectly valid and *does* make sense (and is also supported by
NGLayout, no problem there).
(Assignee)

Comment 1

19 years ago
*** Bug 2011 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
Oops. Misread the spec when adding CSS2 selector support. I thought this was
allowed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.