zip file become corrupted, cannot open again.

RESOLVED DUPLICATE of bug 168098

Status

--
major
RESOLVED DUPLICATE of bug 168098
16 years ago
10 years ago

People

(Reporter: g3martin, Assigned: mscott)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Attach a zip file, and send. The attachment becomes not recognized.

Reproducible: Always

Steps to Reproduce:
1.attach a zip file from mail composer
2.send

Actual Results:  
The zip file attached in the mail in both the inbox and sent box become
corrupted. The a small 690K file, become 1.5M.  Never open it again.


exe or dll file do not have this problem

Comment 1

16 years ago
I can't reproduce this with 20030402 on Windows and 20030331 on Linux.

Martin, would you please test this issue again with a more recent build (like 1.4a)?
(Reporter)

Comment 2

16 years ago
It happened in 1.3 release version.

Comment 3

16 years ago
And? If it's not reproduceable in current builds it's invalid. So do you can
reproduce it with e.g. 1.4a?

This should be a dupe of bug 195009 anyway.
(Reporter)

Comment 4

16 years ago
Created attachment 119554 [details]
zip file that will corrupt

sample zip file that will corrupt itself. It is created by the windows XP
(zipped folder)
(Reporter)

Comment 5

16 years ago
same behavior in 1.4a

Comment 6

16 years ago
I can't still reproduce this problem. Would you please mail me the zip file from
the attachement from your account?
(Reporter)

Comment 7

16 years ago
did you use the zip file that attached on 2003 Apr 5.  send a mail as an attachment.

Comment 8

16 years ago
Thanks for the mail.
The difference between your mail and my tests is, that your attachment uses 
Content-Transfer-Encoding: quoted-printable
and mine
Content-Transfer-Encoding: base64

I don't know exactly if this is the reason. I think quoted-printable isn't
forbidden for attachments in general, but it seems Mozilla has problems
generating it. The mail you sent me contains tabs (\t or 0x09) right in the
encoded stream.

I didn't manage it, to send a attachment encoded as quoted-printable too. Do you
know how to change this encoding?

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

16 years ago
Created attachment 121129 [details]
corrupt attachment

Ok ok, tabs in quoted printable seem to be allowed as I now know.
But the attachment I received is corrupt nevertheless (tried to receive the
mail with another mail app and failed). So here it is, I don't know what to do
with it.
(Reporter)

Comment 10

16 years ago
Created attachment 121196 [details]
the original that I sent you before

Comment 11

16 years ago

*** This bug has been marked as a duplicate of 168098 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.