If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Location Bar Autocomplete remembers redirected URLS only for the current session.

VERIFIED DUPLICATE of bug 112208

Status

()

Core
History: Global
VERIFIED DUPLICATE of bug 112208
15 years ago
15 years ago

People

(Reporter: Max Nokhrin, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

When I go to mail.lycos.com, the server automatically redirects me to
login.mail.lycos.com. Both URLs are saved to the history, but only
mail.lycos.com is saved into the location bar (I checked "match only results
you've typed previously" in the settings). However, this is only for the current
session. As soon as I close the browser completely, mail.lycos.com is removed
from the Location Bar list.

Reproducible: Always

Steps to Reproduce:
1. go to mail.lycos.com
2. go to some other site and then start typing in mail.lycos.com - Mozilla
should automatically find mail.lycos.com
3. close browser and reopen it. mail.lycos.com isn't in the location bar anymore

Actual Results:  
Mozilla lost mail.lycos.com (because it was redirected to login.mail.lycos.com)
when the browser was closed.

Expected Results:  
Mozilla should have kept mail.lycos.com in the location bar.

Comment 1

15 years ago
There is a patch in bug 112208 to not remove these URLs on shutdown.

Just for the record, it's a 302 redirect in use:
HTTP/1.1 302 Found
Date: Tue, 01 Apr 2003 22:59:36 GMT
Server: Apache/1.3.26 (Unix) mod_perl/1.27
Vary: Accept-Encoding,User-Agent
Content-Encoding: gzip
Location: http://login.mail.lycos.com
Connection: close
Content-Type: text/html

*** This bug has been marked as a duplicate of 112208 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
QA Contact: petersen → claudius
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.