page-break-before: always; causes mozilla to crash [@ nsGfxScrollFrame::Destroy]

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Perry Lorier, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

a page that contains:
 <div style="padding-top: 20pt;">
is fine
 <div style="padding-top: 20pt; page-break-before: always;">
crashes mozilla.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Mozilla crashed.

Expected Results:  
Not crashed :)

Sorry, I'll try and do up a proper test case for this later and attach it (if
I've not done so, email me and remind me).  I crashed mozilla 3 times today so
someone should be able to find talkback information about it somewhere.

Sorry I can't be more descriptive, I'm late.

Updated

15 years ago
Keywords: crash
(Reporter)

Comment 1

15 years ago
Created attachment 119589 [details]
Testcase

This is an attachment of a webpage that causes mozilla to crash.  After going
to the print preview menu, clicking "Close" will cause mozilla to crash.  My
browser at work crashes immediately on clicking "Print Preview".  Perhaps a
dangling pointer?

Sorry I wasn't able to reduce it further.

Comment 2

15 years ago
Created attachment 119592 [details]
stacktrace

Comment 3

15 years ago
thanks for the testcase, Perry.

based on the stacktrace, this looks like bug 193686, but the testcase does not
contain a fieldset and only takes up one page.  it still might be the same
underlying bug.

marking NEW for now
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: page-break-before: always; causes mozilla to crash → page-break-before: always; causes mozilla to crash [@ nsGfxScrollFrame::Destroy]

Comment 4

14 years ago
WFM, 2003-11-10-05 trunk Linux,

can anyone reproduce the crash with Mozilla 1.4 or later?

Comment 5

14 years ago
I agree with comment 3, this was most likely fixed by bug 193686.

WFM, Mozilla 1.6a and 2003-11-19-08 trunk on Windows 98 SE.
WFM, Mozilla 2003-11-10-05 trunk on Linux.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsGfxScrollFrame::Destroy]
You need to log in before you can comment on or make changes to this bug.