addFile() returns bogus -1 when installing older version

VERIFIED DUPLICATE of bug 22341

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED DUPLICATE of bug 22341
19 years ago
3 years ago

People

(Reporter: dveditz, Assigned: dveditz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

19 years ago
Both addFile() and addDirectory() return version compare values -4, .. -1 when
the script tries to install a file with an older version than an existing file
and the force flag is not set.

It is correct that the older file is not installed, but it should not be
reported as an error to the script.
(Assignee)

Updated

19 years ago
Assignee: cathleen → dveditz
Target Milestone: M12
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 1

19 years ago
You can now attempt to install an older component and it will correctly be
skipped rather than return a bogus error.

Comment 2

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine

Updated

19 years ago
Blocks: 21564

Updated

19 years ago
QA Contact: jimmylee → depstein

Comment 3

19 years ago
Reassigning QA Contact to David.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 4

19 years ago
not fixed. retested on build 2000011008-M13 (linux, nt and mac). returns -208
(invalid parameter) in logfile:
** ERROR (-208): Skipping: (null)

Install script aborted.
steps:
1) from http://jimbob/trigger2.html, select f_addsubcomp from dropdown. press
trigger case. This installs version 1.0.1.1 in reg package f_addsubcomp.
2) then select f_addsubcomp_vi_no_update from dropdown. Script has older version
(1.0.0.0) w/ force flag = false.
Note: In 4 separate tests, I tested lower major, minor, version and build
components of the version string, and in each case, it returns -208. (in each
case, the .xpi included an earlier test file and it correctly did not install
it).

Also, I tested compareVersion forms of InstallTrigger object and they were
returning expected values for each case.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: FIXED → DUPLICATE
(Assignee)

Comment 5

19 years ago
*** This bug has been marked as a duplicate of 22341 ***

Comment 6

19 years ago
dup. 22341 has been fixed.
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 21564
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.