If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

feature request: disable plug-ins option for *browser*

VERIFIED DUPLICATE of bug 189378

Status

()

Core
Plug-ins
--
enhancement
VERIFIED DUPLICATE of bug 189378
15 years ago
15 years ago

People

(Reporter: David Crick, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030402
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030402

Currently plugins can be disabled for Mail/News.

I would like a check-box for the browser too (or,
at minimum, a "hidden setting" in about:config).

If plugins are allowed for the browser (default):

  * supported plugins should be loaded and run
  * not installed plugins should prompt for d/l

If plugins for browser are turned off:

  * plugins files should not be downloaded/run
  * no prompt should be made to install new s/w

I would very much like to see this option,
particularly (but not limited to!) to turn off
Flash animations and (when Flash not installed)
to stop prompting to install Flash.

We already have the ability to turn off images
(incl. animation of), pop-ups, Java, Cookies,
etc, etc, and this would be another example of
allowing the *user* to filter content and thereby
streamline and speed up their browsing experience

At least one other person supported this idea when
I posted it to netscape.public.mozilla.wishlist.

Given that the short-term future (post-1.4) of Mozilla
will be to *cut back* on configurability, I would very
much like to see this implemented in the 1.4 tree.


Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Isn't bug 94035 the solution ? You could use that to disallow all plugins, or
only for certain types (*like Flash) or sites. See also 19118 (Plug-In Manager).
(Reporter)

Comment 2

15 years ago
re comment #1, yes one of the low-level fixes
given in bug 94035 works for me as an quick fix.

Not very elegant though, so I'd still like to
see another checkbox next to the same option
as already exists for Mail/News.

In the meantime I'm happy though. Cheers!

Comment 3

15 years ago
this is a dupe of Bug 189378

*** This bug has been marked as a duplicate of 189378 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Marking Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.