Java does not work with net sun Java JRE 1.4.2 beta

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: neutropenia, Assigned: zhayupeng)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I'm on Win98SE, using Mozilla today's trunk build, with new Sun Java 1.4.2 beta
installed. We may need to update Mozilla to get it working with this new
version. the java plugins are listed in the "about plugins" dialog, but5 java
applets never load.

Steps:

- Install new java JRE 1.4.2 beta from http://java.sun.com/j2se/1.4.2/download.html

- Go to http://www.bdbiosciences.com/spectra/ or another web site requiring java

- See the result
Please read the component description, thanks
Assignee: ashuk → joshua.xia
Component: Java APIs for DOM → OJI
QA Contact: avm → dsirnapalli

Comment 2

16 years ago
uninstall your older jre and reinstall the latest one.
(Reporter)

Comment 3

16 years ago
About comment #1, sorry, didn't know about OJI component before, I will remember
that one for sure.

About comment #2, this is exactly what I did. I uninstalled the old JRE and
installed the new one. Should I try uninstall and re-install again?

Comment 4

16 years ago
Confirming this bug here too with 2003040308 / XP.  In fact, it's even more
serious - although I'm not raising the severity since there are no actual
crashes or dataloss here.

Ever since installing J2SE 1.4.2 beta, both Mozilla and Phoenix on my system
have been completely buggered.  Even after removing it and going back to
1.4.1_02, neither browser acknowledges that I have Java installed.

Meanwhile, IE works just fine.  I'm still trying to figure out how to get
Mozilla/Phoenix working again so that they recognize I have Java.  (I'll
probably remove them, wipe out all file traces, reinstall, and copy the plugins
back again.)

Comment 5

16 years ago
BTW: You can tell immediately that Java isn't working by trying to query
Bugzilla and being told you don't have JavaScript.
Javascript!=Java and bugzilla doesn't use Java

Comment 7

16 years ago
Okay, in that case, the most recent build broke JavaScript...

Comment 8

16 years ago
Plus it's awfully suspicious that this all started for both me and the reporter
at the time that we downloaded that beta.  Has anybody else who's installed
1.4.2 beta NOT had any issues with Java or Javascript?

Comment 9

16 years ago
Okay - it's not the Mozilla build.  Using a new profile works.  Also, even with
the old build some JavaScript works, just not b.m.o.  I'll try to track down the
profile culprit then see if I can trace it back to the beta install or not.  (If
my contribution here is just so much noise I'll apologize in advance to Martin.)

Comment 10

16 years ago
Totally bizarre.  I now have everything working (Java with the reference URL in
this bug, and JavaScript with b.m.o.) using the 04/04-08 Win32 build and the
1.4.2 beta of J2SE.  None of this worked before.

After comparing my profile files to a backup set I could see no difference. 
What ended up finally "fixing" it was clearing my cache.  Even more bizarre is
that after clearing my Mozilla cache and getting a successful b.m.o. query, I
was suddenly able to also get a b.m.o. query with Phoenix again - even though I
did NOT clear its cache, and the two profile directories are totally separate.

I can't explain any of this - no chain of events I can think of makes any sense
at all.

Martin: I guess that this bug is (now) WFM from where I sit.  Although
*something* definitely happened to my system after I installed the 1.4.2 beta
along with the 4/4-08 build.  Is the URL working for you with IE?
(Reporter)

Comment 11

16 years ago
Thanks for your input Jason. Unfortunately, I have uninstalled IE here at home
and won't reinstall it, so I can't test it on my machine, but it works at my
job, on a computer (W2K) with IE and without Mozilla.

Also, clearing my cache and starting a new profile didn't work either. I really
don't know what more to try.

I wonder if anybody else have this problem, or am I the only one? can anyone
test and confirm?

Comment 12

16 years ago
I am using Mozilla 1.3 final on Windows 2000 and I can confirm this bug. I
installed JDK 1.4.2 beta parallel to 1.4.1 (the last installed JRE becomes the
default JRE) and then I had no Java anymore in Mozilla ("missing plugin").
Copying NPOJI610.dll from 1.4.2 to the plugins directory did not help, but
copying NPOJI610.dll from 1.4.1 did it. Now I have Java again in Mozilla. Seems
that Mozilla really has a problem with JDK 1.4.2.

Comment 13

16 years ago
go to ControlPanel->Java Plugin->Browser, check mozilla1.1 or later on,
you must set this option on or java don't work
joshua:
small question: What changed after 1.1 that there is a special pref for that ?

Comment 15

16 years ago
There is unchange on Mozilla side.
It is change on Java Plugin side (installer and configuration)

Comment 16

16 years ago
The problem with that plugin option in the control panel is, that it does not
find Mozilla on my system and says "Unable ti change Browser settings". Maybe,
because I have installed Mozilla by unzipping and not with the Installer.
(Reporter)

Comment 17

16 years ago
Yes, same for me, I use zip mozilla builds, and I get the same error message. I
clicked OK on the dialog box with the error message, and clicked Apply again. I
thought I had set it right as the Apply button grayed out after that second
click, but closing and re-opening the Java control panel and the Mozilla 1.1 and
later setting is still deselected.

As per comment #15, this isn't really a mozilla issue because the change is on
the Java plugin side (and it is still beta), so I am tempted to INVALID this
bug. Any objections?.

(Also corrected typos in the summary)
Summary: Java does nnot work with net suin Java JRE 1.4.2 beta → Java does not work with net sun Java JRE 1.4.2 beta
(Assignee)

Comment 18

16 years ago
->myself
Assignee: joshua.xia → pete.zha

Comment 19

16 years ago
I also encoutered Martin's problem. I installed JRE 1.4.2 beta in my computer,
and downloaded talkback-enabled Mozilla 1.4 RC2 zip file. After I unzipped the
mozilla 1.4 and launched it, I found that the Java could not be loaded when
visiting the Java-required websites.
After I unstalled JRE 1.4.2 beta and installed JRE 1.4.1_02, Java works.
There must be some bug with the compatibility between mozilla 1.4 RC2 and JRE 1.4.2.

Comment 20

16 years ago
Did you enable Java to support mozilla? set on Java Control Panel.

Comment 21

16 years ago
Joshua, please see Comment #16.

Comment 22

16 years ago
Thomas Boerkel is right. I encountered the same problem with the Java Plug-in in
the Control Panel as is mentioned in Comment #16.

Comment 23

16 years ago
ControlPanel->Java Plugin->Browser->mozilla1.1

By changing a registry, I was able to use this function.

------------------------------------------------------------

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla]
"CurrentVersion"="1.4rc2"

[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org\Mozilla\1.4rc2\Main]
"Install Directory"="C:\\Mozilla\\bin\\"

Comment 24

16 years ago
SuSE7.3:

I have upgraded to 
Java(TM) Plug-in 1.4.2-b28

    File name: libjavaplugin_oji.so
    Java(TM) Plug-in 1.4.2

and it works with MozillaFirebird with libjavaplugin_oji.so out of the ns610-dir.

Mozilla RC3 doesn't even start with that one (I know it's the wrong plugin but
how about an error message?).

/usr/local/mozilla/mozilla
INTERNAL ERROR on Browser End: No manager for initializing factory?

System error?:: Erfolg
chris@tux:~> /usr/local/MozillaFirebird/
bash: /usr/local/MozillaFirebird/: is a directory

I've tried j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so, Mozilla
1.4RC3 starts but doesn't recognize the plugin.

Comment 25

16 years ago
On Win XP SP 1a its the same with the Java 1.4.2 Final. I have Mozilla Firebird
0.6 running, Java 1.4.1_01 worked fine, after updating to 1.4.2 no more Java
support in Firebird.

about:plugins states that everything is correct, it lists the 1.4.2 Java
plugins. In the Java Control Panel I can't activate it for Mozilla 1.1 or higher
as stated in comment #16.

On my other computer I got it running. There I have both Mozilla and Firebird
running. AFTER updating Mozilla to 1.4 RC3 with installer, Java is running in
both Moziall and Firebird. Really strange.
(Reporter)

Comment 26

16 years ago
Yes, my guess is that using the installer might create additional registry keys
and entries, probably a key similar to that mentioned in comment #23. This key
didn'T exist on my system. Unfortunately, adding the key manually didn'T fix the
problem. I may try using an installer build for once soon (Not today: I'm moving
and my internet will be disconnected in a few minutes, for at least 3 days.)

Comment 27

16 years ago
Manually adding the registry values mentioned in #23 fixed my problems and
allowed  me to enable MoZilla Support in the Java Control Panel.
Martin, are you sure you really set the correct path in the .reg file before
importing ? What didn't work after that ? Still the same "mozilla not found"
error in the java control panel ?

BTW: The Java Control Panel copies it's Java DLLs to the plugin directory in the
specified path when activating MoZilla Support. I thought having the Java Plugin
DLLs there would be obsolete by now (since it does work without the DLLs in
there) ? I really wonder what Sun though of when creating this "browser
selection" feature...
(Reporter)

Comment 28

16 years ago
You are right, it works now, even with Java 1.4.2 final. I guess I screwed up
when I tried first time. It even works after deleting java dll's from the
plugins folder as expected. Thanks.

Comment 29

15 years ago
I think this is not an issue anymore, since 1.4.2 final is out and works.
At least on Linux and WinXP.
-> wfm
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 31

15 years ago
On Win98SE at least, it will only work when applying the registry tweak
mentioned in comment #23. It doesn't work "out-of-the-box". 

Comment 32

15 years ago
The same (comment #31) applies to Windows 2000.

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.