Move of incoming spam messages to junk folder can fail due to (too large?) junk log

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: dan.bodoh, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

The automatic move to the "Junk" folder upon download (POP) no longer works. 
Spam gets downloaded, marked as junk, and stays in Inbox.  Problem *might* have
started after I marked a message in Inbox as Junk, and dragged it to Junk folder.

I've un-checked and re-checked UI button, with no success.

If I can get the auto-move working again, I'll try to reproduce the bug.

Workaround is to delete Junk messages by hand.

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

16 years ago
I was able to get the auto-move to Junk working again: disable junk mail
controls, press OK, re-enable junk mail controls, press OK, restart Mozilla.
(Reporter)

Comment 2

16 years ago
Cannot replicate bug with various permutations of dragging messages to/from Junk
folder.

Comment 3

15 years ago
I have the same problem with not junk not automatically moving anymore. I tried
unchecking the junk controls and restarting. I noticed the controls do not
uncheck! It's like the control file that holds these parameters is set to read only.

I started having these problems after I cleared the browser cache (I think it's
called Navigator History). All of a sudden my email account passwords were
deleted, and this spam control was malfunctioning.

Comment 4

15 years ago
*** Bug 213764 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Continues to occur in release 1.5a.

Comment 6

15 years ago
I started having this problem after my initial setup-- after closing Mozilla and
restarting PC so that anti-virus software (PCcillin) would lock onto POP mail.

When I reopened Mozilla, all mail account settings had shifted as required by AV
software (server now "localhost" instead of "pop.mydomain.com"; username now
"me/pop.mydomain.com") and the junk mail filter was acting as described previously.

Comment 7

15 years ago
People who see this problem: have you by any chance enabled the junk mail log?
(tools -> junk controls -> junk mail log) If so, could you _clear_ it so that
it's empty again, and see if that fixes the problem? It did for me, and I thus
suspect first writing entries in a too large junk mail log is the cause of the
move operation then failing. (Which is a bug that still will need fixing, but at
least has a workaround.)

Comment 8

15 years ago
Turning off the junk mail log has alleviated the issue. Looks to be a valid
workaround.

Simply clearing the log did not resolve the issue.

Using 1.5RC1.

Comment 9

15 years ago
confirming and morphing - also based on report from someone I just helped in
#mozillazine who had issues with the move no longer happening with manual moves
(using 1.5 rc1 - winxp).

Dan: if clearing / turning off the junk mail log does _not_ fix the issue for
you, could you note so, so the bug can be morphed back and a new one opened for
what would then be that seperate problem?
Severity: minor → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Move incoming junk messages to Junk no longer happens, even though UI checkbox selected → Move of incoming spam messages to junk folder can fail due to (too large?) junk log
This is what I see.
I have to 2 imap account on an IMAP server.
In the 1st account, it works. On the 2nd account, when I click in the Junk
toolbar button, the email is marked as Junk and then nothing happends.
I can no longer view another email on my INBOX in that account.
If I change to another folder in the same account, sometimes Mozilla crash.
I have 2 incident in the Quality Feedback. When I submit them, will post the
incident numbers here.

I then deleted the junk log files and clicked on "Clear Log" button and now it
is working again. My junk log was like 700kb. Tested on WinXP SP1 Mozilla 1.5rc1
(Reporter)

Comment 11

15 years ago
I haven't had the issue for a while, but I haven't had the log turned on either.
 I've converted to Thunderbird, which I assume is the same back end.  Will turn
on log and wait for bug to appear to try to replicate.
I can confirm this bug still exist in Thunderbird 0.3 RC3

Comment 13

15 years ago
Still a problem in Moz 1.5 under WinXP(Home Edn.) 

The suggested workaround (clearing/disabling event logging) hasn't worked for me
(which I guess you can take as a response to Additional Comment #9 above).

BTW. Is this not a duplicate of 206117?
(Reporter)

Comment 14

15 years ago
Since the date of comment 11, I've been logging junk mail - tens of thousands of
messages - in TB (currently Mozilla Thunderbird 0.3 (20031013)).  The
described bug has not returned.

Comment 15

15 years ago
Unfortunately, moving to TBird 0.3Win (using the suggested strategy of copying
the selected profile's whole folder structure from the previous Moz (1.5)
installation) didn't fix it for me. Not altogether surprising I suppose, as
presumably something's gone astray in prefs.js or one of the other settings
files and of course that now exists for both mail clients. 

I have tried tweaking a couple of settings in prefs.js (usually by using the
about:config utility) including amending spamActionTargetAccount as discussed in
http://bugzilla.mozilla.org/show_bug.cgi?id=192119. This seemed like a good
candidate, not least because my main ISP uses a particularly odd form of
username/hostname combination whereby the mail account username is itself formed
by combining username and hostname, giving a full mail account logon string of
myname@hostname@hostname. Moz had treated this formulation differently for the
two accounts I have with this ISP, apparently drawing upon the .userName and
.hostName fields (though in one instance the .userName was strangely incorrect),
while using .realuserName and .realhostName would have given the correct
combination. [But why do these curiously similar but different fields exist and
where do they get their inputs?] 

In any event, sadly this twiddling has failed to revitalise the +automatic+
treatment of inbound junk, though I should just emphasise that running JMC
manually on my Inbox (POP) does still do the business.

(PS. Should this be a new bug - as the junk logging/log size issue doesn't seem
to apply in this case?)

Comment 16

15 years ago
I've had this problem three times now.

Problem seems to be caused by the junk mail folder being too large.

Solved each time by closing Mozilla, deleting the 'junk' and 'junk.msf' files in
my mail directory, and re-starting Mozilla, which creates new, empty junk folders.

Comment 17

15 years ago
I have found this same bug in a fresh download of v.1.6 (Mozilla/5.0 (Windows;
U; Win 9x 4.90; en-US; rv:1.6) Gecko/20040113) . . . 

I'll attempt some of the fixes posted here, but thought I'd file my experience.

Thanks.

Comment 18

14 years ago
The first fix posted in the comment log solved the problem for me. Here are some
details on how it behaved prior to clearing up:

I experienced the same problems, but have never had logging turned on. Messages
were flagged as junk but not moved from the inbox even though "Move incoming
messages..." was checked in junk mail controls.

I'm on a fresh install of version 0.7.2 (20040707). I have set up 2 IMAP
accounts and 1 POP account and the same problem existed on all three.

So far, my accumulated volume is very small so I would guess that the ideas
about various large mail/logfile volumes in other comments aren't germaine to
the issue. As I'm a new user, my setup is fairly simple.

I did play around with manually moving junk email before setting it up
automatically via the tools menu, so thos trying to reproduce this problem
should act as if they were a new user playing with the GUI to move messages
around to various folders before messing about with the junk mail filtering setup.

Comment 19

14 years ago
I have had this problem as well.  (I use Mozilla 1.8a4 mail on Mandrake 10.) 

Reading through the comments, no one mentioned one thing I did that seemed to
fix the problem for me accidently, so perhaps it is related.  Early on, the
auto-moving of spam to junk folder was working, but then it stopped working at
some point and I didn't know why.  Later, it started working again after I
changed the option for copying my outgoing messages.  It was set to copy to my
inbox; I changed it to copy to another folder (one that is a subfolder of
inbox).  I haven't tried switching back to the inbox to see if moving spam to
junk fails again.

Also possibly related to this problem, while spam in my inbox is auto-moved to
junk as it comes in, for other folders (which are the targets of filters), the
spam is not moved to junk until I click on the folder.

Comment 20

14 years ago
I have the same problem. Junk controls marks the email as junk and leaves in it
the inbox of my pop email. If I mark a message as junk it goes to the junk
folder. I have just downloaded the latest nightly build 11/1, and still have the
problem.
Product: MailNews → Core

Comment 21

14 years ago
OS: WinXP sp1, TB 0.9 (20041103), receive mail via POP3.
I got the problem for the first time immediatly after upgrading to TB 0.9 The
upgrade kept the previous settings: move junk mail to "other" (=spam on Local
Folders), autom. delete after 2 days, when manually marked: delete. No junk log
active.
I changed the settings (no move) and changed them back (move) which at first
seemed to have solved the problem. 
But it didn't. When the problem reappears and I close and reopen TB (no Windows
restart necessary) the problem seems fixed.

The problem reappears every day. I can't reproduce it yet. One possibility:
"editing a new mail while TB at the same time automatically checks the mails and
junk comes in" ?

Updated

13 years ago
Assignee: naving → nobody
QA Contact: laurel

Comment 22

12 years ago
commentors and Dan, do you find that this still fails?  Please update the bug and include your version from help|about
QA Contact: filters

Comment 23

12 years ago
WFM Thunderbird version 1.5.0.7 (20060909)

Comment 24

12 years ago
This seems to work for me now. I went to using spambayes for a while and recently stopped using it to try the thunderbird filter again, so I can't tell you exactly what version it started working on. 

BTW, I'm probably headed back to spambayes because it allows me to set thresholds for definite spam, maybe and definite ham. A little tuning made it almost perfect whereas thunderbird seems to let a lot through- perhaps in the interest of never losing a piece of ham.

Comment 25

12 years ago
Forgot the version for that last comment:

version 1.5.0.8 (20061025) running on windows XP version 2002 sp 2

Comment 26

12 years ago
Windows XP, 1.5.0.9 (20061207)

Since no-one else has replied to say they still experience this bug, I'll say that I'm finding it a problem on two POP accounts. I've moved out the junk filter files (355K and 780K) to see if it solves the problem.

Comment 27

11 years ago
Adam, what do you see when using version 2?  Is(was) your issue really about  _LOG_ size?

Note: I can't find any similar open or fixed or even expired bugs
Whiteboard: CLOSEME 2008-02-15

Comment 28

11 years ago
I have two computers with 2.0.0.9 and it only happens on one, so I may just nuke the profile and re-build it. I almost never see this problem on my main system, but have just realised I had junk logging disabled. I have enabled it and will report back in a week or so.

Comment 29

11 years ago
thanks, but you still haven't answered the question about _log_ size. 

Comment 30

11 years ago
My issue was that mail was being marked as Junk, but not being moved to the Junk folder.

If memory serves, the problem was fine after the junk log was cleared. It would then all work OK until the log file got larger.

Comment 31

11 years ago
OK I have just confirmed this is happening on both of my installs of Thunderbird. Only a few days after enabling Junk logging (and the log growing to 225K) I now have messages in my Inbox marked as Junk but haven't been moved into the Junk folder.
Nominating to keep the bug on the radar.
Flags: wanted-thunderbird3?
Whiteboard: CLOSEME 2008-02-15
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 33

10 years ago
I doubt this has to do with the size of the log - there are other open bugs on mail getting marked as junk but not getting moved. My junk log is 666K now and I don't see any problems. Are no messages getting moved to the junk folder at all once the log gets over a certain size?

Comment 34

10 years ago
marking wanted+, in case this really is the issue.
Flags: wanted-thunderbird3? → wanted-thunderbird3+

Comment 35

10 years ago
Adam, the only way to gauge this for trunk is for you (the only person seeing this) to try it on trunk. Can you test trunk or an alpha and report back, soonish?  http://www.mozillamessaging.com/en-US/thunderbird/early_releases/

Comment 36

10 years ago
(In reply to comment #33)
> I doubt this has to do with the size of the log - there are other open bugs on
> mail getting marked as junk but not getting moved. My junk log is 666K now and
> I don't see any problems. Are no messages getting moved to the junk folder at
> all once the log gets over a certain size?

I haven't seen this problem in a while - but when I did, no messages ever managed to be moved into the junk folder - not automatically, and I seem to recall (but not with 100% certainty) not by manually drag and dropping them either. The problem would persist through restarting, and the only way I ever found to 'fix' it was by deleting the junklog.html file. This file was always "large" (2MB+ iirc), but there wasn't a fixed filesize over which problems happened. It's very possible that the large filesize (and accompanying slow reading time thereof?) simply helped with causing a corruption in this file or something, which was then the real reason for the junk filtering to stop working.

The problem stopped occurring for me after I 
1) deleted a couple of mail filters (across several accounts) which independently moved mail into the junk folder of a single account.
2) stopped using a single junk folder, but instead set up all my accounts to use their own junk folder.

Before that time (so when I had both "manual" filters and automatic junk filtering across several accounts moving to a single junk folder), I saw the problem at least once a month.

Comment 37

10 years ago
After about a week using the current 3.0 alpha 2 dev release and with many messages and large junk mail logs I was not able to re-create this bug once. I would say it seems likely it has been fixed.

Comment 38

10 years ago
Excellent Adam. Thanks. And please comment if you see again.
Cleared wanted-thunderbird3+
=> WFM
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: wanted-thunderbird3+
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.