Customize Toolbar Effect goes up, stops for a second with 1inch left, then continues to go up

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
--
trivial
RESOLVED INVALID
15 years ago
11 years ago

People

(Reporter: Pham, Assigned: David Hyatt)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030329 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030329 Phoenix/0.5

Is the pull down effect neccessary? I noticed that if I opened Task Manager, and
go to View>Toolbars>Customize, there is a 60% jump in CPU usage. That really
doesn't matter, but I guess if you remove the effect, it would make Phoenix more
computer friendly.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
I don't care about mem usage. But everytime I click "done" the palette goes up,
stops for a second, with 1 inch left, and then continues to go away
Summary: Remove pull down effect when customizing toolbar → Customize Toolbar Effect goes up, stops for a second with 1inch left, then continues to go up
(Reporter)

Comment 2

15 years ago
Created attachment 122147 [details]
screenshot of problem

This always happens
1. Go to Toolbars>Customize 
2. Click Done on palette

It has a nice jaggedy down effect, but when goes up, it stops for a sec with
about 1 inch left and then goes away

Comment 3

15 years ago
This is at most an RFE - nevertheless I can confirm this 'stick around' for
about 1/2 second when fading away using Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6 but this doesn't bother me
at all, since I don't make changes to the toolbar every day.
I'd agree with you if this is a functionality you use several times a day in a
regular manner, but in this case I suggest "wontfix".
Severity: trivial → enhancement

Comment 4

15 years ago
I think it's a bug rather than a request of feature enhancement.
Severity: enhancement → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

15 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=171454#c22

I like standard less mem waster dialogs than fun effect

Comment 6

15 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Comment 7

15 years ago
-> performance issue
Keywords: perf

Comment 8

13 years ago
slide animation has been removed for a while --> invalid
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.