If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Use 7-zip for JAR packaging

VERIFIED DUPLICATE of bug 154965

Status

SeaMonkey
Build Config
VERIFIED DUPLICATE of bug 154965
15 years ago
13 years ago

People

(Reporter: Aaron Kaluszka, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
7-Zip's Zip algorithm results in smaller files compared to any other zip
utility.   We should use it to package JAR files.  The source code is available
under LGPL.
> The source code is available under LGPL.

Which means we can't just use it in Mozilla....

Will their zip files decompress with the normal zlib?  If not, is it worth the
bother of shipping two separate decompression libs?
(Reporter)

Comment 2

15 years ago
Yes, the ZIP files will decompress, that's the point of using 7-zip, we don't
have to add any extra decompression libraries into Mozilla.  If we are using the
product for compression rather than incorporating it into Mozilla itself,
wouldn't it be acceptable?  The only reason I brought licensing up at all is
because right now the source is for Win32 only.

*** This bug has been marked as a duplicate of 154965 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
No! Bug 154965 is about packaging Mozilla distributions, not JAR archives.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
> No! Bug 154965 is about packaging Mozilla distributions, not JAR archives.

Mozilla distributions made with zip and JAR archives are created using the same
version of zip.  We're not going to use one version of zip for .jar and the
another version for the .zip just because someone opened a separate bug on it.  


*** This bug has been marked as a duplicate of 154965 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.