Paste text in message without Rich Text

VERIFIED DUPLICATE of bug 64647

Status

MailNews Core
Composition
--
enhancement
VERIFIED DUPLICATE of bug 64647
15 years ago
10 years ago

People

(Reporter: Olivier Vit (just a reporter), Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Rich text support is now great and useful.
However, it can also be desirable to paste a text as plain text, and merge with
the rest of the message without its specific attributes

Reproducible: Always

Steps to Reproduce:
Browse a web page with headers, text in bold, italic, plain text, etc...
Copy a portion of text mixing multiple font sizes and attributes
Open messenger and create a new message (in HTML mode)
Start writing the message and quote third party text
Paste the content of the clipboard


Actual Results:  
Clipboard content is pasted with most of its rich text attributes, and there is
no way to do a 'paste as plain text'

Expected Results:  
Propose an additional option in the Edit Menu to do a 'Special paste' (?)
Else, you need to open Notepad, paste in it, copy again, and paste in your message

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 64647 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v=aha
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.