FTPing with password required multiple password submission.

RESOLVED DUPLICATE of bug 80652

Status

()

Core
Networking: FTP
--
major
RESOLVED DUPLICATE of bug 80652
15 years ago
2 years ago

People

(Reporter: Private, Assigned: dougt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030401

When using FTP servers that require a password, eg: ftp://user123@127.0.0.1 you
are required to enter your password (assuming the account requires one).  But
you have to re-enter the password at each directory that you change to.  So for
example you login to your own ftp you would type ftp://wsbg@127.0.0.1 and you
are given a prompt for your password.  You enter the password and you can
continue.  You select a directory, but again you are asked for your password
again.  Indeed, it seems that every time you want to switch directories you are
again asked for your password if the directory isn't cached.  The problem can be
fixed (a temporary fix) by using login:password@127.0.0.1 instead of just
login@127.0.0.1, so wsbg:mypassword@127.0.0.1 would fix it, while wsbg@127.0.0.1
would exhibit the problem.


Reproducible: Always

Steps to Reproduce:
1.enter <YourLogin>@YourFTPServer.com (login name must have password defined)
2.enter password
3.try to change directory

Actual Results:  
It asked me to enter my password seeming for every single directory that wasn't
in my cache.


Expected Results:  
Asked me for my password once, cache it in memory (not disk), and not ask for it
again until I logout of the FTP server.

Comment 1

15 years ago
did you do a search for existing bugs? if you did, you might have missed it
because it did not contain "password". I've changed the summary to make it more
searchable, please let me know if it needs additional clarification.

Please mark this bug verified if you agree that the two bugs describe the same
problem.

*** This bug has been marked as a duplicate of 80652 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

15 years ago
Severity: normal → major

Updated

2 years ago
Blocks: 1200940
No longer blocks: 1200940
You need to log in before you can comment on or make changes to this bug.