mail date sort improperly uses self-reported date header

RESOLVED DUPLICATE of bug 166254

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 166254
15 years ago
14 years ago

People

(Reporter: Edward Elliott, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.1 (Amiga; U; sparc; en-US) Yeah that's the ticket
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b)

When sorting mail messages by date in the view pane, the date contained in the
"Date:" header of the message is used.  This header is completely unrealiable
since it is set by the sender.  Self-reported timestamps weeks, months, and even
years in the past (or future) commonly occur.  Spammers sometimes manipulate
timestamps in this way, but it also happens with some older email clients that
set the Date header incorrectly after Y2K.  The end result is a date sort can
cause newly received messages to be placed at the bottom of the sort list (or
other non-obvious places).

A better method is to use the transaction date from the last SMTP Received
header, which is controlled by the user's smtp server.  Even the timestamp
Mozilla adds when downloading a message is more reliable than the Date header
(though it's still not advisable; this causes misleading dates when mail is
checked infrequently, or when several messages are downloaded at once and each
receives the same timestamp).

Reproducible: Always

Steps to Reproduce:
1. Send an email to yourself with a Date header in the past (e.g. Jab 4 2001)
2. Download the message into your mozilla mail client
3. Sort the messages by date

Actual Results:  
The new message was placed at the bottom of the sort list with very old messages.

Expected Results:  
Should have appeared near the top of the sort list with other new messages.

Comment 1

15 years ago
I see this behavior in 1.4b
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030408

To easily reproduce in Mozilla, change the pref  mail.compose.other.header
to the string "Date"; then you can compose a message and select Date as one of
the headers.  I pasted in a date from an old message verbatim, since I don't
know how much variety is allowed in this field's formatting.

Reporter, if you change the Severity of this bug to "enhancement" I'll confirm it.  It looks like a good idea to me.
(Reporter)

Updated

15 years ago
Severity: normal → enhancement

Comment 2

15 years ago
Actually, this is a dupe:  Bug 166254

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 166254 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.