RFE: I want to happily view my DocBook/XML pages with the DocBook XSL stylesheet

RESOLVED DUPLICATE of bug 200777

Status

Core Graveyard
Tracking
--
enhancement
RESOLVED DUPLICATE of bug 200777
15 years ago
2 years ago

People

(Reporter: Roland Mainz, Assigned: peterv)

Tracking

(Depends on: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I want to happily view my DocBook/XML pages with the DocBook XSL stylesheet

Steps to reproduce:
1. Download
http://aleron.dl.sourceforge.net/sourceforge/docbook/docbook-xsl-1.60.1.tar.gz
2. Unpack archive 
% mkdir /tmp/docbook_xsl ; cd /tmp/docbook_xsl
% gzcat docbook-xsl-1.60.1.tar.gz | tar -xf -
3. Add DocBook XSL stylesheet location
(/tmp/docbook_xsl/docbook-xsl-1.60.1/html/docbook.xsl) to prefs
4. Browse any DocBook/SolBook/LinuxDoc document
(Reporter)

Updated

15 years ago
Component: XSLT → Tracking
(Reporter)

Updated

15 years ago
Severity: normal → enhancement
Summary: I want to happily view my DocBook/XML pages with the DocBook XSL stylesheet → RFE: I want to happily view my DocBook/XML pages with the DocBook XSL stylesheet
(Reporter)

Comment 1

15 years ago
Does Mozilla already have a mechanism to configure a "default stylesheet" for a
certain DOCTYPE or should I write a RFE for that ?
This is a duplicate of a bug that was talking about exactly this stylesheet
as an example of XSLT sheets Mozilla should apply automatically.

Please find the original (XML component, most likely) and mark this
duplicate.
Whiteboard: DUPEME
(Reporter)

Comment 3

15 years ago
Boris Zbarsky wrote:
> This is a duplicate of a bug that was talking about exactly this stylesheet
> as an example of XSLT sheets Mozilla should apply automatically.
> Please find the original (XML component, most likely) and mark this
> duplicate.

Erm, this is a _TRACKING_ bug to track all issues until a user can really browse
DocBook/XML documents using Mozilla (just making the stylesheet available is not
engougt since the XSLT engine in Mozilla is currently unable to process the XSL
stylesheet and some other issues like crashes happen, too... ;-().
The bug you are mentioning is likely a blocker for this bug - but not a
DUPlicate of this one.
Whiteboard: DUPEME

Comment 4

15 years ago
This is a dupe of bug 109684. As far as any of the two bugs are valid or 
non-WONTFIX. See my comment on said bug about XML CATALOG making this an external
project.

*** This bug has been marked as a duplicate of 109684 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

15 years ago
Axel Hecht wrote:
> This is a dupe of bug 109684. As far as any of the two bugs are valid or 
> non-WONTFIX. See my comment on said bug about XML CATALOG making this an 
> external project.

Regardless of the detail that the stylesheet is not part of Mozilla - these
stylesheets do not work with Mozilla (and even crash it).

Reopening bug until these stylesheets at least work (=no crash and content
browseable) with Mozilla (when they are explicitly referenced in the DocBook
documents) ...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

15 years ago
I suggest reading your bugmail, the crasher moved out of the docbook bug.
And the docbook bug is partly WONTFIX, though AFAICT it wouldn't work from
chrome:// right now, either. That's the part that's open over in bug 200777.

*** This bug has been marked as a duplicate of 200777 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.