Browser won't start if "user agent" line generated from pref bar is present in prefs.js

VERIFIED DUPLICATE of bug 83376

Status

defect
--
critical
VERIFIED DUPLICATE of bug 83376
17 years ago
15 years ago

People

(Reporter: mcenaney, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

I'm not sure if this is a bug in Mozilla or the "Preferences Toolbar" from
XULPlanet. 

If the browser is exited with the "User Agent" in the Preferences Toolbar set to
anything but "Real UA", Mozilla will not start the next time it's launched. 

The offending line in prefs.js looks like:
user_pref("general.useragent.user_prefoverride", "Mozilla/4.0 (compatible; MSIE
6.0; Windows NT 5.1)"); 

In the example above the UA is set to IE-6.0. It could be set to any of the
choices other than
Real UA and the result is the same. 

Removing this line from prefs.js results in Mozilla starting properly again.


Reproducible: Always

Steps to Reproduce:
1. With browser running, set UA in Preferences Toolbar to anything but "Real UA".
2. Quit the browser.
3. Attempt to restart the browser. Browser does not start.
4. Remove the offending line from prefs.js
5. Attempt to restart the browser again. Browser starts.

Actual Results:  
After step #2, browser does not start. 

Expected Results:  
Mozilla should have started normally.

I'm using the snazzy aquaMOZ .99 theme.

Comment 1

17 years ago
I added that specific pref to my prefs.js and Mozilla still worked fine.
Can you try using that pref without the XULPlanet extension and/or an otherwise
clean profile?
Reporter

Comment 2

16 years ago
Ok,

Strange enough, if I add the offending pref line to the prefs.js file manually,
Mozilla 
works fine. But if it gets added by the XULPlanet extension it refuses to start. In 
the latter case if I attempt to start it using "/usr/bin/mozilla -vv" at the xterm 
I get:

----------------------------------------------------------------------------------------
INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: Success
----------------------------------------------------------------------------------------

Also, I noticed that it works fine if the UA is set to "NS 6.2 Lin" 
before quiting. If it's set to anything else (via the XULPlanet extension)
before quitting, it won't start. 

I tossed the prefs.js file (sans offending line) here:

http://www.speakeasy.org/~mcenaney/prefs.js

if that helps. 


*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.