{css1} ugly border edges at line breaks

VERIFIED FIXED in M9

Status

()

Core
Layout
P2
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: Kevin McCluskey (gone))

Tracking

({css1})

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The edges of borders on inline elements are ugly at line breaks.  They have
diagonal ends.

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Assignee: kipp → troy
Status: ASSIGNED → NEW

Comment 1

19 years ago
troy, could you fix this one? It's probably not too bad - the information about
which edges are being skipped is available and could be passed used to do a
better job at rendering...if not, then punt it over to sparky.

Updated

19 years ago
Assignee: troy → michaelp

Comment 2

19 years ago
Michael, I would do this but I think the border code is at the point where it
needs a restructuring. The way MakeSide() is now there are already three cases
per-side (plus the check for one-pixel lines). To add checks and handle the case
for drawing the bevel means duplicating logic many times

Comment 3

19 years ago
Setting all current Open/Normal to M4.

Updated

19 years ago
QA Contact: 4110

Comment 4

19 years ago
setting ChrisD as qa

Updated

19 years ago
Assignee: michaelp → kmcclusk
Target Milestone: M4 → M5
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M5 → M6
(Assignee)

Updated

19 years ago
Target Milestone: M6 → M8
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M9
(Reporter)

Comment 5

19 years ago
I have a fix for this, which I emailed it to kmcclusk.
Summary: ugly border edges at line breaks → {css1} ugly border edges at line breaks
(Reporter)

Comment 6

19 years ago
*** Bug 7126 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

19 years ago
Created attachment 908 [details] [diff] [review]
patch that fixes bug
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
Applied patch in July 27, 1999 5:03PM build.
Verified that it does fix the beveled line endings.
Also viewed CSS1 border test suite.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
Using 8/2 Apprunner, border edges at line breaks look okay. Verifying bug fixed.
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
You need to log in before you can comment on or make changes to this bug.