Closed Bug 201067 Opened 17 years ago Closed 17 years ago

XPConnect leaks XPCNativeScriptableShared objects

Categories

(Core :: XPConnect, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 180380

People

(Reporter: dbradley, Assigned: dbradley)

References

Details

These are intentionly leaked, not sure if there's a way to address this without
some major rearchitecting.

[W] MLK: Memory leak of 76 bytes from 1 block allocated in
XPCNativeScriptableSharedMap::GetNewOrUsed(UINT,char *,XPCNativeScriptableInfo
*) [xpc3250.dll]
        Distribution of leaked blocks
        Allocation location
            new(UINT)      [new.cpp:23]
            XPCNativeScriptableSharedMap::GetNewOrUsed(UINT,char
*,XPCNativeScriptableInfo *) [xpcmaps.cpp:596]
           
XPCNativeScriptableInfo::Construct(XPCCallContext&,XPCNativeScriptableCreateInfo
const*) [xpcwrappednativejsops.cpp:1163]
            XPCWrappedNative::Init(XPCCallContext&,JSObject
*,XPCNativeScriptableCreateInfo const*) [xpcwrappednative.cpp:704]
            XPCWrappedNative::GetNewOrUsed(XPCCallContext&,nsISupports
*,XPCWrappedNativeScope *,XPCNativeInterface *,XPCWrappedNative * *)
[xpcwrappednative.cpp:373]
           
nsXPCComponents::AttachNewComponentsObject(XPCCallContext&,XPCWrappedNativeScope
*,JSObject *) [xpccomponents.cpp:1742]
            nsXPConnect::InitClasses(JSContext *,JSObject *) [nsXPConnect.cpp:438]
            jsdService::OnForRuntime(JSRuntime *) [jsd_xpc.cpp:2426]
            jsdASObserver::Observe(nsISupports *,char const*,WORD const*)
[jsd_xpc.cpp:3237]
            NS_CreateServicesFromCategory(char const*,nsISupports *,char const*)
[nsCategoryManager.cpp:514]
            nsComponentManagerImpl::AutoRegisterImpl(int,nsIFile *,int)
[nsComponentManager.cpp:3191]
            nsComponentManagerImpl::AutoRegister(nsIFile *)
[nsComponentManager.cpp:3402]
            main1          [nsAppRunner.cpp:1092]
            main           [nsAppRunner.cpp:1650]
            mainCRTStartup [crtexe.c:338]
I thought this was a separate leak, but it not.

*** This bug has been marked as a duplicate of 180380 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Marking Verified -
Status: RESOLVED → VERIFIED
I still got this leak after adding the patch of the bug 180380
You need to log in before you can comment on or make changes to this bug.