Image ALT text does not appear on mouseover

VERIFIED DUPLICATE of bug 25537

Status

defect
VERIFIED DUPLICATE of bug 25537
17 years ago
15 years ago

People

(Reporter: rdingman, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

In the page at
http://www.newproduct.molex.com/datasheet.asp?ProductID=42204&BV_SessionID=@@@@1170386138.1049752378@@@@&BV_EngineID=ccceadchmjgmhlfcflgcehedffgdfmk.0&Catalog=
when I place the mouse pointer over the connector figure, the javascript window
does not appear.

Reproducible: Always

Steps to Reproduce:
1. Go to
http://www.newproduct.molex.com/datasheet.asp?ProductID=42204&BV_SessionID=@@@@1170386138.1049752378@@@@&BV_EngineID=ccceadchmjgmhlfcflgcehedffgdfmk.0&Catalog=
2. Place mouse pointer over image of terminal block on right side of screen


Actual Results:  
Nothing happened.

Expected Results:  
A floating popup window with the text "Part Detail" should appear.

The JavaConsole shows:

Error: parent.mainContent has no properties
Source File: http://www.newproduct.molex.com/includes/javascripts/broadvision.js
Line: 24

This works in Netscape Navigator 4.79 for Linux.
I believe Bob is referring to the ALT text "Part Detail" for the image.
Confirming with Mozilla trunk binary 2003040404 on WinNT. OS: Linux --> All.
When I hover the mouse over the image, the ALT text does not come up
as it does in NN4.7 and in IE6:

<a
HREF="javascript:LoadSideMain('http://www.molex.com/cgi-bin/bv/molex/nav/mxleft_nav.jsp?channel=Products&chanName=Series&series=88h2&TYPE=S&BV_SessionID=@@@@1170386138.1049752378@@@@&BV_EngineID=ccceadchmjgmhlfcflgcehedffgdfmk.0&Catalog=','http://www.molex.com/cgi-bin/bv/molex/part/parts.jsp?pageTitle=Series+&series=88h2&BV_SessionID=@@@@1170386138.1049752378@@@@&BV_EngineID=ccceadchmjgmhlfcflgcehedffgdfmk.0&Catalog=');">
<img SRC="http://www.molex.com/product/blocks/882a.jpg"
     BORDER="0"
     ALT="Part Detail">
</a>


Reassigning to Browser-General. I don't know what component this 
belongs in, but it's not JavaScript Engine. JS Engine doesn't
make the ALT text come up. I will attach a reduced testcase below.
Assignee: rogerl → asa
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Browser-General
Ever confirmed: true
OS: Linux → All
QA Contact: pschwartau → asa
Summary: Javascript popup window fails to appear → Image alt text does not appear on mouseover
Posted file Reduced testcase
Try the reduced testcase in NN4.7, IE6, and Mozilla. The ALT text comes up
in the first two, but not in my trunk Mozilla build above.

I don't know the HTML specs for this, but I did check to see that I have
"Accept all images" checked in Edit > Preferences > Privacy&Security > Images.
Summary: Image alt text does not appear on mouseover → Image ALT text does not appear on mouseover

*** This bug has been marked as a duplicate of 25537 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified dupe (invalid/wontfix)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.