Closed Bug 201212 Opened 17 years ago Closed 16 years ago

open link in tab disgards TARGET attribute of A tag

Categories

(SeaMonkey :: Tabbed Browser, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 210986

People

(Reporter: rponton, Assigned: jag+mozilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

On any link with a named target (A TARGET="FOO"), you can open it in a new tab
instead of a new window.  However, the next time you click on a link with the
same TARGET attribute, it will open in a new window, not that already open tab
(unless you force it to open in a new tab).

It *should* just update the tab that was previously opened.

Reproducible: Always

Steps to Reproduce:
1. Make a page with two links,  <a href="foo.html" target="target1">Foo</a> and
<a href="bar.html" target="target1">Bar</a>.  Notice that both links share the
same TARGET attribute.
2. Open the "Foo" link in a new tab.
3. Left-click on the "Bar" link.

Actual Results:  
You have your original browser window with the original page and a tab for
foo.html as well as a new browser window for bar.html.

Expected Results:  
It should have opened bar.html in the tab originally opened for foo.html.

It is my opinion that the current behavior is incorrect, but I realize it may be
that way on purpose and others may not share my opinion.
bug 210986 or bug 121377

*** This bug has been marked as a duplicate of 210986 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.