Closed Bug 20142 Opened 21 years ago Closed 21 years ago

Crash submitting form within IFRAME.

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 19376

People

(Reporter: myk, Assigned: pollmann)

References

()

Details

Overview Description:

When browsing a page with an IFRAME, mozilla crashes if the first thing I do is
submit a form within that IFRAME.  Mozilla doesn't crash if I click on a link
within that iframe, then go "back" and submit the same form.

Steps to Reproduce:

1) Open test case (http://www.zapogee.com/~myk/tc1.html).  Bugzilla search page
opens within iframe (also tested with other pages with forms).
2) Search for any bug: Enter bug number (f.e. 20102) in search form at top of
page and submit form.
3) Watch mozilla crash.
4) Restart mozilla, reload test case, and click any link within IFRAME page (for
example, Search Existing Bug Reports).
5) Right-click within page and select "Back".
6) Enter bug number in search form at top of page and submit form.
7) Watch mozilla load search results.

Actual Results:

The application crashed.

Expected Results:

The application loads the results of the form submission.

Build Date & Platform Bug Found:

Linux RedHat 6.0 i386 Nightly Build 1999112208

Additional Builds and Platforms Tested On:

None

Additional Information:

None
Assignee: karnaze → pollmann
Eric, please take a look.
Update: I downloaded the latest build (1999112608 Linux), and I am not
experiencing this problem with this build.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
works fine with native scrollbars - dup of 19376

*** This bug has been marked as a duplicate of 19376 ***
Status: RESOLVED → VERIFIED
Marking as verified duplicate of 19376.
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.