download manager profile persistance resricts new browser startups

RESOLVED DUPLICATE of bug 100179

Status

SeaMonkey
Download & File Handling
--
major
RESOLVED DUPLICATE of bug 100179
15 years ago
13 years ago

People

(Reporter: Artur Jackson, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

If all browsers exit while downloads are still queued in the download manager,
the download manager's session seems to keep a lock on the profile it was
started with, therefore inhibiting successive startups of a new browser. The new
browser cannot start because the previously used (still in use) profile is still
in use.

Reproducible: Always

Steps to Reproduce:
1. start a download (large enought that wt will give you time to exit the
broswer before it finishes :| )
2. exit all instances of the browser (leaving download manager open!!)
3. try and start a new instance of the browser
Actual Results:  
There will be a lock on the previous profile preventing you from starting a new
session with it.


Expected Results:  
When last browser instance exits while download manager still has downloads
queued, it should notify, via IPC (a simple signal would do.. if the USR defined
signals arent used up yet.. ill check the source in a minute), the download
manager and have it release its lock on the current profile, yet allow the
downloads to complete (run in a detached manner).
use ctrl+N

*** This bug has been marked as a duplicate of 100179 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.