Mozilla should open a new Navigator window when app is brought to front with no windows open

VERIFIED DUPLICATE of bug 90823

Status

--
minor
VERIFIED DUPLICATE of bug 90823
16 years ago
14 years ago

People

(Reporter: Daryl, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312

The Mac OS X convention is for a running application, when brought to the front
(i.e., by clicking on its dock icon or double-clicking its application icon)
with no open windows, to open a new window. Mozilla should therefore open a new
Navigator window (or even better, add a preference as to which Mozilla window
type (if any) should be opened in this case) when brought to front with no open
windows.

Reproducible: Always

Steps to Reproduce:
1. Close all Mozilla windows but don't quit the application
2. Bring another application to the foreground (i.e., click on the desktop
background to bring the Finder to the foreground)
3. Bring Mozilla to the foreground (i.e., by clicking on its icon in the Mac OS
X dock); note that a new Navigator window is not opened

Actual Results:  
A new Navigator window is not opened.

Expected Results:  
A new Navigator window should have been opened.

Comment 1

16 years ago
This is bug 90823 and has recently been fixed. When possible, please test with
the most recent nightly build before submitting a bug.

(btw, the window type specified in Preferences > Appearance is the one that will
be opened)

*** This bug has been marked as a duplicate of 90823 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.