hmco.com - Reloads if I resize window

RESOLVED INVALID

Status

Tech Evangelism
Desktop
--
minor
RESOLVED INVALID
15 years ago
3 years ago

People

(Reporter: Ben, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [havefix], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

As Netscape does, Camino reloads on web pages that use CSS and have told
Netscape browsers to reload after a window resize. This was frustrating,
especially when I had entered tons of form data and made the mistake of resizing
the window.

Reproducible: Didn't try

Steps to Reproduce:
1. Go to a site that reloads if the browser is Netscape.
2. Resize the window.
Actual Results:  
The site reloaded, clearing form data.

Expected Results:  
The site should not reload; form data should remain.

Comment 1

15 years ago
Ben, please provide an example URL.
(Reporter)

Comment 2

15 years ago
http://college.hmco.com/cgi-bin/SaCGI.cgi/ace1app.cgi?FNC=AcePresent__Apresent_html___his_bailey_38

Comment 3

15 years ago
Tech Evangelism, it's that site's own fault. In function reDo in
<http://college.hmco.com/shared/javascript/menu.js>, they test
navigator.appVersion for the presence of "Netscape" and the *absence* of "4.0"
to determine whether or not to reload. What they meant to do was test for the
*presence* of "4.0".

That is, we see:

if(navigator.appName=="Netscape" && navigator.appVersion.indexOf("4.0")==-1)

where we would expect to see:

if(navigator.appName=="Netscape" && navigator.appVersion.indexOf("4.0")!=-1)

Actually, it's silly for them to test for browser version here, since they
already do extensive browser sniffing in
<http://college.hmco.com/shared/javascript/platform.js> and
<http://college.hmco.com/shared/javascript/common_functions.js>.
Assignee: saari → susiew
Status: UNCONFIRMED → NEW
Component: General → US General
Ever confirmed: true
Product: Camino → Tech Evangelism
QA Contact: winnie → zach

Comment 4

15 years ago
In Moz 1.4a OSX, the quiz selections are retained after the resize, avoiding
dataloss.

Contact addresses are support@hmco.com and
http://college.hmco.com/cgi-bin/SaCGI.cgi/college/catalog.class?FNC=GoWriteToUs__Fcust_serv_midpage_html

Severity: normal → minor
OS: MacOS X → All
Hardware: Macintosh → All
Summary: Reloads if I resize window on CSS sites → hmco.com - Reloads if I resize window
Whiteboard: [havefix]
(Reporter)

Comment 5

15 years ago
The same goes for Internet Explorer 5.x.

Comment 6

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Comment 7

14 years ago
See bug 235871:  The same problem, adding a skin that resizes on a page load,
causes continuous reloads.

Comment 8

9 years ago
URL is now broken although problem still remains in the JS, so I suppose reporter should provide a new URL.
Status: NEW → UNCONFIRMED
Marking this as new -- if this does not happen anymore, reporter can mark as resolved or others can comment saying so.
Status: UNCONFIRMED → NEW
redirected to http://college.cengage.com/redirect/ace_redirect.html?FNC=AcePresent__Apresent_html___his_bailey_38

the quiz doesn't exist anymore.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: English US → Desktop
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.