Left/right smooth scrolling with arrow keys crashes Navigator

VERIFIED DUPLICATE of bug 199607

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 199607
15 years ago
14 years ago

People

(Reporter: Erik Demaine, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401

This seems very reproducible, at least on Windows XP (I've sent in various crash
reports): the left and right arrow keys combined with smooth scrolling crash
mozilla.  I have not tested without smooth scrolling, but I assume that's the
problem.  Scrolling up and down with arrow keys is fine, as is scrolling with
mouse clicks on the scrollbars.

Reproducible: Always

Steps to Reproduce:
1. Enable smooth scrolling in 1.4a
2. Load any page that has significant horizontal content.
3. Resize the window to be fairly narrow horizontally so that the bottom
scrollbar appears.
4. Use the right arrow key to scroll right, after having enabled smooth scrolling.

Actual Results:  
Complete crash, causing talkback to load.


I'm sorry, I don't have a talkback crash ID, but the last few crashes under
edemaine@mit.edu should be examples of this problem.

Comment 1

15 years ago
This is fixed in recent nightlies.

*** This bug has been marked as a duplicate of 199607 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.