Add target frame frame of hovered-link to status bar

RESOLVED DUPLICATE of bug 14027

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 14027
15 years ago
14 years ago

People

(Reporter: Rick Bull, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

With Konqueror when you hover over a link whose target is another frame/window
it appends "(in other frame)" to the URI in the status bar. It would be very
handy to have that feature, especially for new windows (target="_blank"). Here
is an example JavaScipt I think (haven't tested it) you could use in a web-page
(although it would interfere with any other onmouseover events in the document):

function setLinksStatus() {
  for (var linkIndex = 0; linkIndex < document.links; linkIndex++) {
    var currentLink = document.links[linkIndex];
    if (currentLink.href && currentLink.target) {
      currentLink.onmouseover = new Function("window.status = this.href + ' (in
the frame/window ' + this.target + ')'");
    }
  }
}

Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

15 years ago
OS: Linux → All
Hardware: PC → All

Comment 1

15 years ago
this is a dupe of bug 14027

*** This bug has been marked as a duplicate of 14027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.