History forgets to remember some addresses like http://www.newsforge.net

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
3 months ago

People

(Reporter: deleted48206, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030412
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030412

It's really amazing. The history contents all visited addresses and pops them up
quickly after typing in some letters into the URL locator bar. But with
http://www.newsforge.net it does not work though I can find it in the history.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.newsforge.net
2. Visit another place
3. Type in "www.news" into the URL locator bar
Actual Results:  
Nothing happens though the address is stored in the history.

Expected Results:  
It should have offered the whole address "http://www.newsforge.net" for
selection in the history list below the URL locator bar.

This happens at least since Mozilla 1.2
Problem is, we're not treating a 301 redirect as meaning we should save the
entry in urlbar history....

Comment 2

16 years ago
This is a redirect issue. If you enter a address that is then redirected the
address is not added to the history. It should be added to the histroy. I have
verified it on the Linux Platform using Mozilla 1.4 build 2003052807.

Comment 3

14 years ago
this worksforme (sorta).  typing "www.news" gives me www.newsforge.com, which
seems to be the current behavior (bug 112208 covers not storing
www.newsforge.net, assuming it was typing into the URL bar).

Comment 4

14 years ago
this worksforme more now than before... at step 3, I get www.newsforge.net and
www.newsforge.com

resolving WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

3 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.