Warn before deleting an address book

VERIFIED FIXED in M17

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: rzach, Assigned: vparthas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] ui)

(Reporter)

Description

19 years ago
If I understand correctly, the personal address book is treated differently than
other additional address books.  If so, it should not be possible to delete it;
especially since there seems to be no way to recreate it once deleted.

Updated

19 years ago
QA Contact: lchiang → esther

Comment 1

19 years ago
zach - can you list the build date of the Linux build you are using? Thanks.
(Reporter)

Comment 2

19 years ago
I deleted mine on 199911520 (M11) Linux; I'd rather not do it again (had to
delete and recreate the profile to fix it).

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13

Updated

19 years ago
Summary: Shouldn't be able to delete PAB → Warn before deleting PAB

Comment 3

19 years ago
I don't think the personal address book is special at all. You should be able to
delete it, but it would be nice if gave a warning first, and had "No" as the
default button in the dialog.

Updated

19 years ago
Target Milestone: M13 → M15

Comment 4

19 years ago
Bumping to M15
CCing self -- I was just about to report a bug, `"Delete address book" should 
have confirmation dialog'. This should apply to all address books, not just the 
PAB.

Updated

19 years ago
Whiteboard: ui

Comment 6

19 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16

Comment 7

19 years ago
Not M16 stopper.  Moving to M17.  Please add keyword beta2 if this is a beta2 
blocker.
Target Milestone: M16 → M17

Comment 8

19 years ago
Mass move mailnews bugs to Putterman.  Ouch.
Assignee: hangas → putterman
Status: ASSIGNED → NEW

Comment 9

19 years ago
Mail Review recommends beta2 stopper.  Adding nsbeta2 keyword.
Keywords: nsbeta2

Comment 10

19 years ago
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: ui → [nsbeta2+][6/01]ui

Comment 11

19 years ago
Due to slip in schedule, moving this bug from [6/01] to [Will be minus on 6/15] 
for fix deadline.
Whiteboard: [nsbeta2+][6/01]ui → [nsbeta2+][Will be minus on 6/15]ui

Comment 12

19 years ago
reassiging to varada.  It might be useful to look at how mail does this for
deleting folders.
Assignee: putterman → varada

Comment 13

19 years ago
*** Bug 42081 has been marked as a duplicate of this bug. ***

Comment 14

19 years ago
Try this text (similar to 4.x) "Deleting 'address book name' will erase 
its mailing lists and cards. Are you 
sure you want to delete this address book?" Followed by an Yes and No
button (instead of OK and Cancel).

Comment 15

19 years ago
User should get a confirmation dialog before deleting ANY of their ABs.
Ok, that's three saying it should be any address book and not just the PAB, so 
resummarizing.

Jennifer, `Yes' and `No' is bad for the same reason `Ok' and `Cancel' is bad: 
`Would you like to continue without deleting your address book?'. You get the 
idea. :-)

Easy design:

+---------------------------------------------+
| Delete Address Book ::::::::::::::::::::::::|
+---------------------------------------------+
| /!\ Are you sure you want to delete the     |
| `-' "Baker Street Irregulars" address book, |
|     including all of its cards and mailing  |
|     lists?                                  |
|                                             |

Ideal design:

+---------------------------------------------+
| Delete Address Book ::::::::::::::::::::::::|
+---------------------------------------------+
| /!\ The "Baker Street Irregulars" address   |
| `-' book contains 118 cards and/or mailing  |
|     lists. Are you sure you want to delete  |
|     this address book permanently?          |
|                                             |

Bottom of either dialog, Mac/Unix:

| [?]                 (( Cancel )) ( Delete ) |
+---------------------------------------------+

Bottom of either dialog, Windows:

|     ( Delete ) (( Cancel )) (  Help  )      |
+---------------------------------------------+
OS: Linux → All
Hardware: PC → All
Summary: Warn before deleting PAB → Warn before deleting an address book
(Assignee)

Comment 17

19 years ago
Accepting bugs
Status: NEW → ASSIGNED

Comment 18

19 years ago
I'd like to have an extension on this bug. Perhaps until 6/22?  This is similar 
to deleting a folder in the folder pane.  It's easy to forget where one has 
focus and given that we have no trash for the address book, not putting a dialog 
can make it very easy to delete important information easily.

Comment 19

19 years ago
PDT agrees beta stopper. Removing [6/15] from status whiteboard
Whiteboard: [nsbeta2+][Will be minus on 6/15]ui → [nsbeta2+] ui
(Assignee)

Comment 20

19 years ago
Marking Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 21

19 years ago
Using build 2000-06-23 on win98, mac and linux this is fixed.  verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.