Camino keeps deleting bookmarks.xml file on quit

VERIFIED FIXED

Status

Camino Graveyard
Bookmarks
--
critical
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: neilio, Assigned: Conrad Carlen (not reading bugmail))

Tracking

({dataloss})

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030327 Chimera/0.7+ BeatnikPad
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/2003041205 Chimera/0.7+

I saw this happen with an earlier nightly and the problem was somehow rectified
(though I can't remember how), but I've noticed that Camino is automatically
deleting the bookmarks.xml file from my profile every time I quit. In its place
is a "_bookmarks_temp.bak" file.

I've tried adding bookmarks, reimporting them, deleting the entire profile
directorry and starting from scratch, and every time Camino quits, my
bookmarks.xml file is toasted. Help!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Neil, do you have any kind of unusual disk setup, like UFS or remote volumes?
Can you reproduce this using another *OS X* user account, or another machine?
Keywords: dataloss
(Reporter)

Comment 2

15 years ago
> Neil, do you have any kind of unusual disk setup, like UFS or remote volumes?

I have my Users directory mounted from another volume, but I've had it like this
for a while and have been using Camino / Chimera without any problems until a
couple of days ago.

> Can you reproduce this using another *OS X* user account, or another machine?

Not yet, not, which is what confuses me. I'm not having problems with any other
applications, however.
(Reporter)

Comment 3

15 years ago
I figured out what the problem was:

If you do not have a "Temporary Items" folder in your Users folder
(/Users/Temporary Items), Camino will delete the Bookmarks.xml file on quit
every time. Once I added a Temporary Items folder in the proper place and set
the permissions to be 777 my bookmarks file isn't deleted.

This is a rare occurance, but it should be looked at!
(Assignee)

Comment 4

15 years ago
Apparent regression from bug 195148, which changed the way we got the temp
folder. Sean, I thought you were creating such folders if they didn't exist.

Comment 5

15 years ago
I did, but querying for the user temp folder under OSX does not return:
  /Users/Temporary Items

It returns:
  /private/tmp/9299/Temporary Items

Actually, it will return the above path for all of the system domains
(kOnSystemDisk, kOnAppropriateDisk, kSystemDomain, kLocalDomain, kNetworkDomain,
and kUserDomain).

Comment 6

15 years ago
Confirming bug, I see this with builds 2003051705 and 2003052404, but _not_ with
the official 0.7 (200300613). I also have the user accounts on another partition
than the system, have not tried the workaround in comment 3 yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

15 years ago
This needs to be fixed - it's still in the latest nightlies, and still as major
a data loss as there ever was.

Comment 8

15 years ago
pink, want to take a look?
Assignee: sfraser → pinkerton
(Assignee)

Comment 9

15 years ago
I can take a look. I have an account on my machine with the home dir on another
drive.
Assignee: pinkerton → ccarlen

Comment 10

15 years ago
I no longer can reproduce this, neither with the latest nightly nor the builds
mentioned in comment 6. Maybe this have been fixed with the latest system
update(s) (I am running 10.2.6 now)?

Comment 11

15 years ago
Neil, are you still seeing this?
(Reporter)

Comment 12

15 years ago
I unfortunately can't run a test case for this any more, as I've changed my system's environment 
and no longer mount my Users folder from another partition. I did do some more testing just 
before I switched back and it seemed to be okay.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

15 years ago
Because I haven't seen this in quite a while, I'm changing to FIXED - can anyone with their Users 
folder mounted from another partition verify?

Comment 14

15 years ago
Verifying since I do not see this any more either (with my uers folder stil on
another partion).

If someone still see this, please reopen and report your OS version.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.